• Advertisement
Sign in to follow this  

[java] JOGL In Slackware 10 HELP PLEASE

This topic is 4807 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Ok...I have been bashing my head up against my desk now for a couple of days trying to get JOGL to work in Slackware Linux. I have read tons of docs and posts and to no avail I still can't get it to work. I put the .so files in my jre/bin directory and the jogl.jar file in the jre/lib/ext directory. Also I have played with the ldconfig and java class path to get it to work but still get this error: Exception in thread "main" java.lang.UnsatisfiedLinkError: no jogl in java.library.path at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1682) at java.lang.Runtime.loadLibrary0(Runtime.java:822) at java.lang.System.loadLibrary(System.java:992) at net.java.games.jogl.impl.NativeLibLoader$1.run(NativeLibLoader.java:60) at java.security.AccessController.doPrivileged(Native Method) at net.java.games.jogl.impl.NativeLibLoader.<clinit>(NativeLibLoader.java:46) at net.java.games.jogl.impl.x11.X11GLContextFactory.<clinit>(X11GLContextFactory.java:50) at java.lang.Class.forName0(Native Method) at java.lang.Class.forName(Class.java:164) at net.java.games.jogl.impl.GLContextFactory.getFactory(GLContextFactory.java:69) at net.java.games.jogl.GLDrawableFactory.createGLCanvas(GLDrawableFactory.java:150) at net.java.games.jogl.GLDrawableFactory.createGLCanvas(GLDrawableFactory.java:118) at net.java.games.jogl.GLDrawableFactory.createGLCanvas(GLDrawableFactory.java:85) at ffbe.FinalFantasystyleBattleEngineMain.<init>(FinalFantasystyleBattleEngineMain.java:37) at ffbe.FinalFantasystyleBattleEngineMain.main(FinalFantasystyleBattleEngineMain.java:70) Yes I realize that it says no jogl in java.library.path, so how does one know what your java.library.path is, because that might solve my problem... Any help at all would be greatly appreciated.

Share this post


Link to post
Share on other sites
Advertisement
Guest Anonymous Poster
I might be wrong but I think the .so files go in /usr/lib or /usr/local/lib. At least someplace in your LD_LIBRARY_PATH.

Only the jar files go into jre/lib/ext.

Share this post


Link to post
Share on other sites
Guest Anonymous Poster
Someone buggered up the way that java on linux looks for native libraries.

The standard workaround is to add the following to your command line:

-Djava.library.path=.

and have the libs in the current directory (or whatever path you prefer).

What almost never works is to just put the libs where all the other libs for linux go - which would be what everyone expected to do.

IIRC this has now been fixed, or else there's a better workaround, but I've not bothered upgrading from that one :).

redmilamber

Share this post


Link to post
Share on other sites
Yay got it to work in eclipse also....had to add the -D etc to the vm argument list. Thank you all for your help :-)

Share this post


Link to post
Share on other sites
Don't forget to also do it when setting up your JNLP file for webstart. Although...I'm pretty sure there's an easier way to do it in webstart and/or it's automagically fixed there.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement