Sign in to follow this  
Hedos

Apache server. Accessible from local network, but not from the internet.

Recommended Posts

Hey, I have recently setup an Apache server on my Linux machine. Apache was already installed in the Slackware installation and the service automatically starts at boot-up. I am able to access the website from another PC on my local network by tiping its local address in my browser ( 192.168.1.102 ).. But it is impossible from its Internet IP address.. I always receive this message: "The connection was refused when attempting to contact.." in my browser. So I am wondering if any of you guys could give me a few suggestions on where to look to resolve the problem? What might possibly be the cause?

Share this post


Link to post
Share on other sites
192.168.whatever.whatever isn't a real IP address. It's a local IP address which your router assigns to your computer.

You need to study up on NAT as it relates to your router, and figure out (a) what your real IP address is, and (b) how to open up a port to your server.

Share this post


Link to post
Share on other sites
I know that ;)
I said I CAN access it from my local network ip address but I CAN'T access the web site from my internet ip address, which I know. (It is 66.130.219.x)

Also, I have all the ports on my linux computer open from my router.

Share this post


Link to post
Share on other sites
You might want to set BindAddress * in the config if it isn't already. That'll make Apache bind on all interfaces.

If that doesn't work chances are your ISP is blocking port 80.

Share this post


Link to post
Share on other sites
you must use NAT port FORWARDING to forward the port the web server uses (usually port 80) to the internal ip address the computer uses (192.168.1.102)

this tells the router, (which has the ip address 66.130.219.???) that when IT (the router) receives a request on port 80, to send that request to the internal computer at address 192.168.1.102 (hence the term FORWARDING) ... just like email forwarding, one computer gets the email and forwards it to another ... in this case the router gets the http request and forwards it to the server.

Share this post


Link to post
Share on other sites
Quote:
Original post by Ra
You might want to set BindAddress * in the config if it isn't already. That'll make Apache bind on all interfaces.

If that doesn't work chances are your ISP is blocking port 80.


BindAddress * was commented out in httpd.conf, I uncommented it.
I'm now rebooting the computer.
I'm wondering, how could I restart apache without rebooting?

As for the port 80, I already verified, my ISP is not supposed to be blocking it.

Share this post


Link to post
Share on other sites
Quote:
Original post by Xai
you must use NAT port FORWARDING to forward the port the web server uses (usually port 80) to the internal ip address the computer uses (192.168.1.102)

this tells the router, (which has the ip address 66.130.219.???) that when IT (the router) receives a request on port 80, to send that request to the internal computer at address 192.168.1.102 (hence the term FORWARDING) ... just like email forwarding, one computer gets the email and forwards it to another ... in this case the router gets the http request and forwards it to the server.


Oh, thanks a lot, I understand now, everything work :)

Share this post


Link to post
Share on other sites
To restart apache without rebooting, look in /etc/init.d for the apache daemon--usually named apache or httpd--and issue a 'restart' command to it. For example, if your apache daemon is named apache, you would do this:

# /etc/init.d/apache restart

Share this post


Link to post
Share on other sites
Quote:
Original post by Hedos
I'm now rebooting the computer.
I'm wondering, how could I restart apache without rebooting?


#apachectl restart

Check the man page for apachectl there are many options:
Usage: /usr/sbin/apachectl {start|stop|restart|reload/graceful|closelogs|update|status|configtest}

Share this post


Link to post
Share on other sites
Quote:
Original post by bytecoder
To restart apache without rebooting, look in /etc/init.d for the apache daemon--usually named apache or httpd--and issue a 'restart' command to it. For example, if your apache daemon is named apache, you would do this:

# /etc/init.d/apache restart


I don't have any init.d file/folder.
I'm using Slackware 10.0..
I'd be interested to know where can I setup all the things which are loaded at startup?
Well, anyway, apache is not here for me..

Quote:
Original post by acraig
Quote:
Original post by Hedos
I'm now rebooting the computer.
I'm wondering, how could I restart apache without rebooting?


#apachectl restart

Check the man page for apachectl there are many options:
Usage: /usr/sbin/apachectl {start|stop|restart|reload/graceful|closelogs|update|status|configtest}

Thanks!

Share this post


Link to post
Share on other sites
Sign in to follow this