Jump to content
  • Advertisement
Sign in to follow this  
kemm10

Dev-C++ compiling problem

This topic is 5050 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Whenever I first try to compile a project with Dev-C++ 4.9.9.0, I get an error message stating [Build Error] No rule to make target `all'. Stop. and a window pops up stating "Could not create Makefile!!!". This only happens when I try to compile the program after first creating the new project. If I exit Dev-C++ and reopen the project, it compiles fine. I had a similar problem with an earlier version of this program, but never found out what was wrong.

Share this post


Link to post
Share on other sites
Advertisement
Since none replies and it reminds me of some issues I met when I dealt with DevCpp the first few hours ... still I am a bit too tired to remember the details or extrapolate your case. I'll maybe give more details tomorow, ping back here (I bookmarked) if you are still stuck. Meanwhile, I suggest :

- you elaborate your question more :
-- give some details on "what kind of project ?"
(windows .exe?, .dll?, static library?, console .exe ?)
-- what kind of files in your project ?
-- libs linked
-- etc ...
-- which steps you followed to make it (and fail).

- you try simple test projects
-- console with a C main and printf.
-- then if it works, something more difficult closer to your project.
-- etc ...

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!