Jump to content
  • Advertisement
Sign in to follow this  
AndiDog

OpenGL GLSL ain't working!

This topic is 5042 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I tried using GLSL shaders in OpenGL, but all I get is a black screen. Compiling works and the shader code is definitely right. Besides, other parts of my application that don't use shaders are working as usual. I also downloaded a GLSL tutorial from codesampler.com. It didn't work either. Do you have any solutions (my graphics card is a nVidia GeForce Ti 4200) ???

Share this post


Link to post
Share on other sites
Advertisement
Your graphics card does not support ARB fragment shaders in OpenGL. You can only use vertex shaders in GLSL.

Share this post


Link to post
Share on other sites
did u download the nvemulate.exe toll from nvidia this will let u run shaders in software gf4 only supports vertex shader in hardware

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!