Sign in to follow this  
jumpjumpjump

[web] PHP's session,use_trans_sid and xhtml strict...

Recommended Posts

[rant] I am about fed up with php's freaking retarded way of passing SID's with forms. I mean they could have at least cared to make it work for XHTML strict, but no! They have to make me spend about an hour and a half trying to find a way to make it validate without success. Arg! [/rant] Anyway, if you want to see what I am talking about, visit: http://validator.w3.org/check?uri=http%3A%2F%2Fcrxgames.com%2Fspade%2Fportal%2Fprofile.php%3Fmode%3Dregister&charset=%28detect+automatically%29&doctype=%28detect+automatically%29. Anyone know how to fix that? I have tried using ini_set and setting session.use_trans_sid to false with no avail. Anyhelp would be worth a representation in the credits. ;)

Share this post


Link to post
Share on other sites
Is it Apache 1 or 2?

You have to tell your web server that you don't want trans_sid before the first page is server for every user.

Use this for Apache2:

php_value session.use_trans_sid 0

You have to put that in the virtual host configuration or in a .htaccess file (if you have enabled them).

I think (I hope) that should work.

If you use another http server tell us.

Hope it helps,

Share this post


Link to post
Share on other sites
I'll try .htaccess, didn't want to, but if there is another way to do it in php please tell.

I am using apache.
Apache Version: Apache/1.3.33 (Unix) mod_jk/1.2.6 mod_gzip/1.3.26.1a mod_auth_passthrough/1.8 mod_log_bytes/1.2 mod_bwlimited/1.4 PHP/4.3.9 FrontPage/5.0.2.2634a mod_ssl/2.8.21 OpenSSL/0.9.7a

The master value for the trans session id is on... :(

Share this post


Link to post
Share on other sites
Yeah, the cheap .htaccess way. I think it has to do with either the php version of the way it was compiled.

If my host's php was compiled as a module for apache then the ini_set of the session trans id does nothing(which is waht is happening to me), but if php is compiled on its own with its modules it works.(hence why it worked on my local test server.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this