• Advertisement
Sign in to follow this  

HLSL, .NET needed?

This topic is 4811 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I am programming in C++ with visual studio on directx. I recently picked up "Programming Vertex and Pixel Shaders", by Wolfgang Engel. I skipped through and read random pages to get a feel for how it was written. I didnt notice that on the opening page, it says I NEED .NET. I dont program in .NET and I handle all my memory on my own. Do I need to re write my entire game to use HLSL? This part really gets me. Besides that why would they make you run .NET? Maybe im confused here, or it was over stated in the book, can sum1 PLESE clearify this for me? Thanks much. Brad

Share this post


Link to post
Share on other sites
Advertisement
You'll want Visual Studio .NET for doing shader debugging. Microsoft officially don't support VC6 with the latest release of the DXSDK.

Share this post


Link to post
Share on other sites
Sorry for late reply, I just got back into town late last night. Im in the midst of upgrading anyways. BUT I take it you dont have to upgrade, its just if I want to be "officially" supported? heh ohh good ole' microsoft :).

Thanks

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement