Sign in to follow this  

Help Need

This topic is 4735 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

hI, I m using DirectX9.0 with VC++6.0 but the problem is that its support upto DirectX3 or some other version but Direcx 9.0 is not.so when i making any object of any interface i coudnt see the property or function of that object.so how can it possible to view that thing..... i already adjust the Direct x 9.0 library and include files in VC++6.0 directory. but i m not able to see the auto list member,code comments,auto type info,auto parameter info ...etc and i already checked all the option.so plz help me....its urgent..........

Share this post


Link to post
Share on other sites
Most probably ... make sure that you are having the DX9 directories on top of the list.

For more functionality ... you might want to look at the Add ons that come for Microsoft VC++, they help and color the syntax very neatly :)

Share this post


Link to post
Share on other sites
A sticky topic right at the top of this forum does mention that DX9 9 (dec version) is not compatible with VC 6. Your problems may well be linked with this unless u r using the october version.

Share this post


Link to post
Share on other sites
If you're talking about IntelliSense (MSVC's auto-complete feature) not working properly, then AFAIK it's related to a problem with MSVC 6.0.

To get auto-complete information for DX9 in MSVC 6.0, you'll need to add the DirectX header files to the workspace for your project as described in the FAQ for this forum: http://www.gamedev.net/community/forums/showfaq.asp?forum_id=10#autocomplete

An alternative which will also get you extra features is to purchase a copy of Visual Assist from http://www.wholetomato.com/


If you're having problems compiling and/or linking your DirectX based code, then make sure the paths to both the include and library files in the DirectX 9 SDK are set up in MSVC (Tools -> Options... -> Directories). Also make sure that the DirectX 9 paths are at the *TOP* of the path lists so that MSVC doesn't find older files first.

Share this post


Link to post
Share on other sites

This topic is 4735 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this