Sign in to follow this  

[web] ColdFusion problem

This topic is 4728 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I'm having a rather strange problem with my current web application. The user logs in at index.cfm. Their login info is checked at LoginVerification.cfm. If all their info is correct, it automatically redirects them to DoctorPage.cfm. After this the problem starts... On DoctorPage.cfm, there are a number of links. If you click on any of these links it throws an error saying that the user is not logged in. The EXACT same verification code is at the beginning of all the pages (except index and LoginVerification.) But it only works on DoctorPage.cfm. This is my verification code by the way:

<cfapplication name="PatientTracker2" sessionmanagement="yes" setclientcookies="no">

<link href="css_page.css" rel="stylesheet" type="text/css">

<cfif IsDefined("SESSION.Auth.IsLoggedIn") EQ FALSE >
	<cfoutput>
	< p >< b >< big >ERROR - USER NOT LOGGED IN< /big >< /b >< /p >
	< p >< a href="index.cfm" >Return to main page.< /a >< /p >
	</cfoutput>
	<cfabort>
</cfif>
The session variables seem to work for only half the site. Any help would be great, thanks!

Share this post


Link to post
Share on other sites

This topic is 4728 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this