Sign in to follow this  

[.net] problem with precompiled headers

This topic is 4761 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Having troubles with my program and i believe it has something to do with my project settings for precompiled headers. This is what i have: my main cpp file, vector.h/cpp and polygon.h/cpp. vector.h includes math, polygon includes vector and gl/gl.h, and main includes windows.h, gl/gl.h, gl/glu.h, gl/glaux.h and polygon.h i've tried setting all of them to 'using precompiled headers' and i get: fatal error C1010: unexpected end of file while looking for precompiled header directive i've tried setting them all to 'not using precompiled headers' but i get a ton of errors mostly in gl.h and a couple in vector.cpp which say 'identifier not found' even though it's with regards to a variable that i defined in the vector class in vector.h. Including windows.h in the files that use gl (main and polygon) gets rid of the gl.h errors but keeps those vector errors that i mentioned. Any ideas?? this is very frustrating and any help would be much appreciated...thanks!

Share this post


Link to post
Share on other sites
It's normal for GL/gl.h to require windows.h, but I'd be taking wild guesses as to your problem with vector.h/.cpp without looking at the source. Are you sure vector.cpp is including vector.h?

Share this post


Link to post
Share on other sites

This topic is 4761 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this