Jump to content
  • Advertisement
Sign in to follow this  
species8472

DirectSound Issue

This topic is 4967 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi All , I've written a pretty simple - straightforward DSound player lib to be used in games etc ... It works fine in a test app , eg simple Windows Form. The problem comes in when used in the actual game , when a click_event occurs , I play a sound , however , the sound cuts off abruptly. This happens every time . Its rather weird. I am using C# . Does anybody have any idea as to why this happens ? Thanks.

Share this post


Link to post
Share on other sites
Advertisement
The code would be pretty much the same as that used in the DXSamples folder.
I think i know wot the problem is ... my DSound class inits a app. buffer every time ..

eg.
DSound a = new DSound();
DSound b = new DSound();

Thereby killing the prev sound buffer ... is this correct ?

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!