• Advertisement
Sign in to follow this  

Terrible Problem

This topic is 4787 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

when my program runs to HRESULT hResult = PDIRECT3D->CreateDevice(0,D3DDEVTYPE_HAL,g_hWnd,m_D3DCREATE_MULTITHREADED|D3DCREATE_MIXED_VERTEXPROCESSING,&m_PresentationParam,&m_pD3DDevice); then my computer reset. does anybody know why??? if you know any possible reason, plz tell me~!! thanks a lot

Share this post


Link to post
Share on other sites
Advertisement
Most likely a problem with your video card driver but if you could post what values are you filling in for the presentation parameters there may be a problem there.

Share this post


Link to post
Share on other sites
Presentation parameters I set is here:

PresentationParam.BackBufferWidth = pMode->Width;
PresentationParam.BackBufferHeight = pMode->Height;
PresentationParam.BackBufferFormat = pMode->Format;
PresentationParam.BackBufferCount = 1;
PresentationParam.MultiSampleType = D3DMULTISAMPLE_NONE;
PresentationParam.SwapEffect = D3DSWAPEFFECT_COPY;
PresentationParam.hDeviceWindow = g_hWnd;
PresentationParam.Windowed = TRUE;
PresentationParam.EnableAutoDepthStencil = TRUE;
if ( pMode->Format == D3DFMT_A8R8G8B8 || pMode->Format == D3DFMT_X8R8G8B8)
{
PresentationParam.AutoDepthStencilFormat = GetDefaultDepthStencilFormat(32,8);
}
else
{
PresentationParam.AutoDepthStencilFormat = GetDefaultDepthStencilFormat(16,0);
}

PresentationParam.Flags = D3DPRESENTFLAG_LOCKABLE_BACKBUFFER; PresentationParam.FullScreen_RefreshRateInHz = D3DPRESENT_RATE_DEFAULT;
PresentationParam.PresentationInterval = D3DPRESENT_INTERVAL_IMMEDIATE;

Share this post


Link to post
Share on other sites
I think what I fill is ok.
The problem only happened on 5700.
TNT2, Geforce2, Geforce4 are all ok.

Share this post


Link to post
Share on other sites
Guest Anonymous Poster
Most likely your setting something that your video card doesn't support then. Try updating drivers, etc otherwise just use one of the other cards.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement