• Advertisement
Sign in to follow this  

Problem loading images

This topic is 4795 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

i am trying to get Nehe's BMP Loading code to work in my Program but when I compile I keep getting the error, undefined reference to 'auxDIBImageLoadA@4' What is wrong with the code , I copy and pasted directly from the Tutorial, so I dont know whats going on.

Share this post


Link to post
Share on other sites
Advertisement
thats a linker error, you need to link glaux.lib into your application.

HOWEVER, the aux library is outdated rubbish, get a better imaging loading library such as
- DevIL
- Corona (C++ style)
- Freelibrary

or even just roll your own if you fancy remaking the wheel....

Share this post


Link to post
Share on other sites
Quote:
Original post by Sir Sapo
i am trying to get Nehe's BMP Loading code to work in my Program but when I compile I keep getting the error,

undefined reference to 'auxDIBImageLoadA@4'

What is wrong with the code , I copy and pasted directly from the Tutorial, so I dont know whats going on.


Well, first of all you have to link with the glaux library (don't know it's name though, because I've never used it). But that's your current problem.
Secondly, I would strongly advise you to either use an existing library or make your own image loader (not hard at all), because glaux has quite a few memory leaks.

Share this post


Link to post
Share on other sites
Visit http://www.wotsit.org for details on file formats.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement