Sign in to follow this  

SDL

This topic is 4714 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Well, I created a game in SDL over the summer, my first full one (simple as it is), and haven't touched it since. Since then, I have wiped and redone my main hard drive (the game is on the secondary one). So, I reinstalled Dev-C++ yesterday, put the SDL library into "Include," and compiled it. I got several errors. I realized that this was because I had not changed the link to the SDL library from C:\Dev-C++\Include\SDL to D:\... so I did that, and it compiled. Now, however, when I try to run the program, which compiled fine, I get this message: The procedure entry point SDL_SetModuleHandle could not be located in the dynamic link library SDL.dll. What could be causing this?

Share this post


Link to post
Share on other sites
I sounds like you are not using the correct SDL.dll file. Check to make sure whatever version of SDL you installed you have the right .dll in the project folder or the system32 folder if you have winxp - or system if you have pre-winme. What version of SDL are you using? Also check the sdl.dll you have and see it's version.

Share this post


Link to post
Share on other sites

This topic is 4714 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this