Sign in to follow this  

Strange error 'n' stuff

This topic is 4709 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Strange stuff happening... My project (OpenGL with SDL) was going along all fine (but nothing big yet), until I started textures. I try to do the texture loading with SDL_Image, and, after a whole lot of coding, and a whole lot of debugging, it finally compiles and links properly. But now I'm getting an error I never saw before: "The procedure entry point SDL_Error could not be located in the dynamic link library SDL.dll" I have no idea what this means... So after a google search I find exactly 1 page, which tells me to upgrade to SDL 1.2.8. That's all very sweet, but now the SDL homepage seems down. So, is there anything else I can do except wait until the home page resurrects? And can someone enlighten me about that error? It seems more windows-specific then SDL-specific, but since I know nothing about the technical stuff of DLL's, I have no clue... *EDIT* OK i found 1.2.8 by google cache... Installed it and it worked :). Still wanting to know what that error was, if anyone reads this... Thanks, -Amarth [Edited by - Amarth on January 17, 2005 4:41:46 PM]

Share this post


Link to post
Share on other sites
Someone else had this problem recently as well. It was located here.

Quote:
Original post by Drew_Benton
I sounds like you are not using the correct SDL.dll file. Check to make sure whatever version of SDL you installed you have the right .dll in the project folder or the system32 folder if you have winxp - or system if you have pre-winme. What version of SDL are you using? Also check the sdl.dll you have and see it's version.


That was why - incorrect .DLL compability with the third party libraries with SDL.dll.

- Drew

Share this post


Link to post
Share on other sites
I think I understand... The SDL_Image-version I got used SDL 1.2.8, wile I still had SDL 1.2.7 installed at that time. Well, that makes sense :-). Thanks!

-Amarth

Share this post


Link to post
Share on other sites

This topic is 4709 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this