Jump to content
  • Advertisement
Sign in to follow this  
Thrust

Problems installing SDL_Image and Sfont

This topic is 4928 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hey, Yesterday I tried adding in a font library to my current project but yet I couldnt find the proper way to install either SDL_Image or Sfont. I tried messing around and this is what I got: Files/GnuWin32/lib/libpng-bcc.lib" ../../../../../Program Files/GnuWin32/lib/libpng-bcc.lib: file not recognized: File format not recognized make.exe: *** [sffkt.exe] Error 1 Execution terminated Is there a place I can download a devpak for both? I have a devpak for SDL_Image but it wont let me install, it says im missing SDL which is right on the devpak installer.

Share this post


Link to post
Share on other sites
Advertisement
I actuially fixxed the SDL_Image problem, but I have no idea how to install SFont. Is there a faq somewhere on how to do it?

Share this post


Link to post
Share on other sites
Ah please somebody. If anyone here uses SFont can you tell me where to install the files it has please. Thank you.

Share this post


Link to post
Share on other sites
From the SFont main page:

Quote:
You don't need any extra libs - just add the tiny SFont.c (4K) to your objects!


Or if you like you could compile SFont into it's own library then link with that in your app.

Share this post


Link to post
Share on other sites
When I download SDL_Image it tells me how to install it, and I followed it, I also added SFont.c to my project, and I still get a hell of alot of linker problems, them telling me that SDL.h doesent exist, I dont get it. No matter what I do I cant get it to work on the stupid project. All I want is an easy way of drawing text to the screen, that isnt the stupid cone3d example which is rediculously long for what Iwant to do.

Share this post


Link to post
Share on other sites
if you are using Dev-C++, the sdl headers get installed in a different way like: <SDL/SDL.h> or <SDL/SDL_image.h>

Maybe that is the problem,
Joshua

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!