Sign in to follow this  

Creating .lib file

This topic is 4714 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

While trying to setup SQLite3 to compile without warnings owith my vs.net ide, i ran into this : MSVC and SQLite DLL Creation of an import library from the sqlitedll.zip (http://www.sqlite.org/sqlitedll.zip) for MS Visual C++ is achieved by the following command: LIB /DEF:sqlite.def This makes the files sqlite.lib and sqlite.exp files. The sqlite.lib can then be used to link your programs against the SQLite DLL. --------------------- My question is : where do you write this "LIB /DEF:sqlite.def" ??? thanks [Edited by - md_lasalle on January 18, 2005 9:12:57 AM]

Share this post


Link to post
Share on other sites
After trying what you said the compiler gives me that error :

gkEditor fatal error LNK1104: cannot open file 'LIB/DEF:sqlite3.def'

i tried removing the word : "LIB" from the line, did not give any errors but no Libs were generated

thanks...

****EDIT*******************************

i looked in the Debug directory of my project and it appears that a .lib file has been created :)

Share this post


Link to post
Share on other sites
LINK will automatically create the import library for you. However, the /DEF option (according to MSDN) should ONLY be used from the command-line, not from the development environment. (Although it doesn't say why.)

Share this post


Link to post
Share on other sites
ok i have the lib.exe file but the sqlite3.lib that is created doesnt seem to work properly... when linking i have this error :

gkEditor fatal error LNK1103: debugging information corrupt; recompile module

maybe i missed some parameter of the lib.exe command...

Share this post


Link to post
Share on other sites
At the command prompt. Make sure that your compiler's BIN path is in your PATH environment variable, else you'll have to type that too.

It has worked for me as recently as last night when I rebuilt my laptop.

EDIT: I was using VC6. You need to follow these instructions to get a working binary for .NET.

Share this post


Link to post
Share on other sites
E:\Program Files\Microsoft Visual Studio .NET\Vc7\Bin;
E:\Program Files\Microsoft Visual Studio .NET\Common7\IDE

Thank you very much, by including these path to the PATH Environnement Variable, the correct lib.exe was used and evrything is working fine now...

thanks to evryone who helped.

Share this post


Link to post
Share on other sites

This topic is 4714 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this