Sign in to follow this  
d000hg

Island Racers DEMO 003

Recommended Posts

d000hg    1199
UPDATE - A new exe is up (9th February) which should be more stable and tell me why it was crashing previously at startup for some people Hi guys. The newest version of my racing game project project, now with sound and music, can be downloaded from here. Screenshot Read the readme.txt file first for controls and please post back with your thoughts. Thankyou. [Edited by - d000hg on February 28, 2005 1:59:21 AM]

Share this post


Link to post
Share on other sites
Marmin    523
Is this demo running in Full-screen? Or in a window?
Can you please include a setup, or make the game full-screen, so I can adjust some parameters.
Because, it's running extremely slow (1 fps), and I think this is caused by wrong window size.
Thanks, looks nice! How big is this game?

Share this post


Link to post
Share on other sites
d000hg    1199
It runs in a window which takes up the whole screen. So Direct3D is set up to use whatever your windows screen mode is, which might be a bit high.
Was it slow right from the start or did it suddenly slow down while running - did pressing 'R' to reset it make a difference?
Do you have more thn one monitor on your system - if so try moving the window to the other monitor(s).
Could you email me the 'game log.html' file produced at john.dexter@fsmail.net please? I can customise a version to use maybe 640x480x16bit fullscreen if you want to try that.

Share this post


Link to post
Share on other sites
Marmin    523
Quote:
Original post by d000hg I can customise a version to use maybe 640x480x16bit fullscreen if you want to try that.


I can't ask you to do that of course. But my card needs it, I think.
I'm testing the game on a low-end graphic card. I think the card wants the game to run full-screen (not windowed), or in a fixed window mode (like 800x600), to get a decent frame-rate.

Share this post


Link to post
Share on other sites
Qa303asmGuru    163
Crashed on startup. Looks cool though. Below is the log created trying to run it on one of the lab computers. I'll give it a whirl on my comp at home later. What was the next item that was supposed to be on the log list? That might give a better idea of what went wrong...

log:

*****************Opened a log file*****************
Creating a D3D COM object...succeeded with 1 adapter(s):
NVIDIA RIVA TNT2 Model 64/Model 64 Pro (Microsoft Corporation)
D3DCLASS - Initialised D3D ok
D3DClass::CreateDevice(0=NVIDIA RIVA TNT2 Model 64/Model 64 Pro (Microsoft Corporation)) : Using SW vertex processing
D3DClass::CreateDevice : About to set 1600x1200, F=22 Df=80...SUCCEEDED


Share this post


Link to post
Share on other sites
jakem3s90    437
Quote:
Original post by Qa303asmGuru
Crashed on startup. Looks cool though. Below is the log created trying to run it on one of the lab computers. I'll give it a whirl on my comp at home later. What was the next item that was supposed to be on the log list? That might give a better idea of what went wrong...

log:
...


I'm getting the same thing, except my resolution's 1024x768.


*****************Opened a log file*****************
Creating a D3D COM object...succeeded with 1 adapter(s):
NVIDIA GeForce4 MX 440 with AGP8X
D3DCLASS - Initialised D3D ok
D3DClass::CreateDevice(0=NVIDIA GeForce4 MX 440 with AGP8X ) : Using HW vertex processing
D3DClass::CreateDevice : About to set 1024x768, F=22 Df=77...SUCCEEDED

Share this post


Link to post
Share on other sites
d000hg    1199
Oh for crying out loud! I've just had this problem with two ATI-based machines and now nVidia too?! I've run it on a TNT2 myself at home! I think it might be sound-related but my logging isn't catching anything.
The new link at the start of the post is to a version which lets you choose between windowed and 640x480x16 fullscreen mode. You only need to download the latest .exe (2nd file) not the whole thing again if you ahve it already.

Share this post


Link to post
Share on other sites
Qa303asmGuru    163
Cool!

One thing-
In your readme.txt you have n and m labeled as change up and change down respectively. It took me a few minutes to realize that meant changing gears...so you might want to change it to shift up/down. Not a biggie, just a little confusing at first.

The physics were cool, I hope you release another version where the cars can run into each other ;)

Oh and the game did in fact crash when you drive into the ocean. When I got to the edge the car did a backflip in the air, but when I kept driving out the whole game crashed.

Another thing, in windowed mode I get about 25-30 fps, in fullscreen I was getting ~90-100!! It is normal to get higher fps in fullscreen, but I don't think I've ever seen that much of a performance difference!

This game has great potential...keep going with it!

Share this post


Link to post
Share on other sites
d000hg    1199
Yeah, driving into the ocean means you go pass the edge of the level. In theory there's code in place to handle it (an infinite flat plane you can drive on) but in practice it doesn't work. I'll just stop you going off the map at some point...
The difference in framerate probably is down to the resolution. In fullscreen mode it uses 640x480 at 16bit colour. I'd imagine your windows desktop to be at least 1024x768, maybe 1280x1024 and using 32bit colour. That's up to 4X as many pixels to draw!

Share this post


Link to post
Share on other sites
You're not supposed to directly link to the download; link to the post instead. When you made this thread, I had forgotten to prevent hotlinking to downloads, but I implemented it a week or so ago, and if you try clicking the download links, you'll see it doesn't work. (I found this post because someone tried downloading it today and the error was logged.) So you may as well edit your original post, d000hg. And shame on you! [smile]

Share this post


Link to post
Share on other sites
Guest Anonymous Poster   
Guest Anonymous Poster
my anti-virus scanner popped up a virus alert Trojan.Qhosts, after opening your .exe

uh oh

Share this post


Link to post
Share on other sites
d000hg    1199
Quote:
Original post by CGameProgrammer
You're not supposed to directly link to the download; link to the post instead. When you made this thread, I had forgotten to prevent hotlinking to downloads, but I implemented it a week or so ago, and if you try clicking the download links, you'll see it doesn't work. (I found this post because someone tried downloading it today and the error was logged.) So you may as well edit your original post, d000hg. And shame on you! [smile]
Sorry about that - I'll update it...

Share this post


Link to post
Share on other sites
d000hg    1199
Quote:
Original post by Anonymous Poster
my anti-virus scanner popped up a virus alert Trojan.Qhosts, after opening your .exe

uh oh
My anti-virus software at home is pretty up-to-date and didn't detect anything. I also took it to work which has very good protection system and nothing was detected there either. Are you sure it actually came from my .exe, and you didn't just catch it while online at the time you downloaded by demo? Did your sofware report the infection in my .exe or just at the time it was run/later on?

This site says that virus is not transmittable via a .exe - it cannot infect files. I have to conclude my demo is clean.

Share this post


Link to post
Share on other sites
Sign in to follow this