Jump to content
  • Advertisement
Sign in to follow this  
n0ob

Winsock HTTP talking to Google

This topic is 4909 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I'm messing around with Winsock and HTTP and I was trying to connect to Google to do a search. Google seems to not like me, and I cannot get any data from them at all. I can search using Yahoo, which is nice. Any ideas on why a simple GET www.google.com/search?q=frown doesn't work here? Thanks!

Share this post


Link to post
Share on other sites
Advertisement
Guest Anonymous Poster
You should use SOAP.

http://www.google.ca/apis/

Share this post


Link to post
Share on other sites
Go to the link provided by the AP. The web service is really easy to use. I got my C++ app up and running with it in about 20 minutes. If you have any questions about how to use it, PM me.

Share this post


Link to post
Share on other sites
Guest Anonymous Poster
You just need to properly format your HTTP request. Google doesn't know the difference between you and IE if you set it up right.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!