Jump to content
  • Advertisement
Sign in to follow this  
stroma

cant use oop basecode

This topic is 4972 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

hi, i can build and run the nehe oop basecode but when i want to add my 3ds loader class to it, it cant render my model. i tried my code @glut and my code works ok. what can be the problem? i can post the code, if neceserry (but i dont think, i think this is a general problem) thank you very much..

Share this post


Link to post
Share on other sites
Advertisement
okey i see the problem is i am defining the model in the application class and if i make it global it works.
so why does it happen? how can i use an object in another class? i tried pointers but could not make it work..

Share this post


Link to post
Share on other sites
Why are you using OO base code if your not coding in a OO way?

There are many ways to do this, I suggest you use google for a beginers tutorial on OO.

Share this post


Link to post
Share on other sites
of course i know oo basis but there is something wierd. i mean i try my system in another basecode "as same" and it worked but it did not work with nehe ogl framework. and i just ask are teher anything i may miss about opengl? or oop?

anyway i solved the problem with some fake..
Thank you.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!