Sign in to follow this  
crazedfool

sudden slowdown in even simple rendering

Recommended Posts

About two weeks ago my hardrvie got corrupted and I just reinstalled windows over itself to save my files. The next time I came back to my puny engine I was only getting 4 FPS, whereas before something around 100-150 was normal. So I went through my entire game loop commenting out sections and didn't manage to find anyhting to account for the sudden slowdown. Disabling everything except clearing the window every frame leaves me at only 100 FPS, doing only GUI rendering drops me right back down to 4. It was about this time that I also noticed that now the drivers were reporting that I had only 3 extensions instead of the 50 or so my card supports. I figured it must be some kind of driver glitch but I've just installed the latest drivers for my old Radeon 7200 and nothing has changed. I took a build over to my friend's house where it runs at about 70 (no vsync). His computer is almost brand new and I brought over the version doing nothing but GUI rendering so it seems this should be faster. I can't see where it's going wrong. Is there some kind of setup option i may have misspecified? I'm dead positive i haven't touched my GUI code but perhaps I messed the renderer up a bit and changed some state. I've been fighting this for two weeks now and have no idea. I seem to be able to run other games fine, bf1942 might be a little slower but not very noticably. I'm out of ideas

Share this post


Link to post
Share on other sites
You may be rendering in software mode. Try the following:

cout << glGetString(GL_VENDOR) << " " << glGetString(GL_RENDERER) << endl;

If it says Microsoft Corporation Generic GDI, then you are running in software mode, and that is why you are getting such poor frame rates.

Share this post


Link to post
Share on other sites
.\renderer.cpp(489)Renderer::Renderer - Microsoft Corporation
.\renderer.cpp(490)Renderer::Renderer - GDI Generic

Darn, and stronger adjectives. I'm using SDL for initialization, and haven't changed anything with regard to how it's set up. I specify SDL_OPENGL. I just updated my video card drivers and I can't be running bf1942 in software. What flag could do this to me?

Share this post


Link to post
Share on other sites
SOLVED IT! my desktop had been shifted to 16bit during the reinstall and I hadn't bothered to set it back. Apparently this caused rendering to occur in software, frame rate back up to over 200.

Rate++ for cwhite

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this