Jump to content
  • Advertisement
Sign in to follow this  
graveyard filla

getting RAID 1 in windows?

This topic is 4938 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

does anyone know if its possible to setup software RAID 1 in Windows? ive googled and it seems its windows server only.. but is there a way to hack it or something maybe? thanks for any help.

Share this post


Link to post
Share on other sites
Advertisement
Software RAID features are now server-only in Windows. I don't know if they used to be present on NT workstation, but they're now only the server versions.

However, hardware (IDE) RAID boards are very cheap and offer advantages over software RAID. Windows workstation OSs will support these too.

- You can boot off hardware RAID even if the first drive has failed (s/w RAID requires the first drive to be working in order to boot on most BIOS)
- You can share it between multiple OSs because it looks just like a normal HD
- Potentially more performant?

(Note that RAID is not an acceptable replacement for backups)

Mark

Share this post


Link to post
Share on other sites
Agreed. I was considering RAIDing my two drives, but i just went out and bought a 160GB external drive for backing up. Now that my data is off the main HD's, i feel strangely safe (i've suffered HD failure before).

Share this post


Link to post
Share on other sites
hey guys,

well, the reason i ask is because i just put togeather the server hardware for the dedicated server for my MORPG. i have installed Fedora on it, but im having a nightmare of a time setting this thing up. im getting problems trying to setup the MySQL DB, RAID 1, and i am having a hell of a time getting the server to compile (not because of windows dependencies, but because i just cant get the development environment setup properly). now i want to run in RAID 1 so if a disk ever fails i dont lose the game database all the way to the last backup, and i already purchased the hardware so new hardware is out of the question. i was thinking of wussing out and just putting Windows on the box, but no RAID 1 is stopping me from doing that.. i guess i was just hoping there was maybe a program or some sort of trick to get it to work. this is pretty much my first time using Linux, and i guess im just getting frustrated and inpatient (ive been working for 10 months to get my client/server in working condition and now i have purchased the hardware, i just cant get the bastard server to compile!).

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!