Sign in to follow this  

Transparent model ?

This topic is 4687 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi. I'm have many troubles for day after day with DirectX :-). I'm loading .x mesh. It's no problem, but model has "transparent" textures. All across this textures (faces) are visible too :-O. I trying to set all CULL modes, but model looks still same. What i doing wrong ?

Share this post


Link to post
Share on other sites
So the original mesh (authored in some other editor I presume) uses textures that have transparencies in them. These "transparent" areas are still visible when you render your mesh using DirectX. Correct?

Cull modes aren't relevent here, it would be about alpha blending if anything - D3DRS_SRCBLEND, D3DRS_DESTBLEND and D3DRS_ALPHABLENDENABLE should be the settings you want to read up on.

hth
Jack

Share this post


Link to post
Share on other sites
Quote:
Original post by jollyjeffers
So the original mesh (authored in some other editor I presume) uses textures that have transparencies in them. These "transparent" areas are still visible when you render your mesh using DirectX. Correct?

Cull modes aren't relevent here, it would be about alpha blending if anything - D3DRS_SRCBLEND, D3DRS_DESTBLEND and D3DRS_ALPHABLENDENABLE should be the settings you want to read up on.

hth
Jack


I'm tried show model without textures (not same model ... this model haven't textures) and have same result.

D3DRS_ALPHABLENDENABLE is FALSE, D3DRS_ALPHATESTENABLED is FALSE.
D3DRS_SRCBLEND and D3DRS_DESTBLEND ... i'm tried many combinations, but still same.

I'm really don't know, what i make wrong :-((.

Share this post


Link to post
Share on other sites
Quote:
Original post by Instruo
wait... why would you want to have alphablendenable and alphatestenable set to false if you're trying to do alpha blending?


I'm not to trying to do alpha blending. Model is still alphablended and i'm to trying stop this. Back vertexes of the model must be hidden.

Share this post


Link to post
Share on other sites
Your description isn't very accurate. Are you sure you're seeing actual transparency? If you've already disabled alpha blending, then perhaps you're seeing other faces because of a lack of Z buffering. Are you sure you've enabled Z buffering?

You might simply want to post a screenshot of what is going on.

Share this post


Link to post
Share on other sites
Quote:
Original post by Kippesoep
Your description isn't very accurate. Are you sure you're seeing actual transparency? If you've already disabled alpha blending, then perhaps you're seeing other faces because of a lack of Z buffering. Are you sure you've enabled Z buffering?

You might simply want to post a screenshot of what is going on.


Yes. ZBuffer is enabled (ZWriteEnable too).

How to post picture here ?

Share this post


Link to post
Share on other sites
Quote:
Original post by PetrCBR
Quote:
Original post by Kippesoep
Your description isn't very accurate. Are you sure you're seeing actual transparency? If you've already disabled alpha blending, then perhaps you're seeing other faces because of a lack of Z buffering. Are you sure you've enabled Z buffering?

You might simply want to post a screenshot of what is going on.


Yes. ZBuffer is enabled (ZWriteEnable too).

Hot to post picture here ?


Screen is here :
http://directx.pjsoft.net/wing.png

Share this post


Link to post
Share on other sites
Quote:
Original post by PetrCBR
Outsch ... stencil buffering make this problem ! I solve this.

Thanks all to yours help !

Purely out of curiousity, you say stencil buffering is your problem.. that screenshot you posted really looks like a simple depth buffering issue to me!

Care to explain, in more technical detail, what it was that you fixed?

Cheers,
Jack

Share this post


Link to post
Share on other sites

This topic is 4687 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this