Sign in to follow this  
fproto

Alpha Blending Messed Up

Recommended Posts

fproto    344
Hey guys. I've done this so many times before, and not once has it turned out like this. [image] The left is the one with alpha, the right one is opaque. My blending is set to SRC: SRCALPHA, and DEST: INVSRCALPHA. I enabled depth testing. My model was imported from 3DS Max, and I disabled culling. Please help. Thanks.

Share this post


Link to post
Share on other sites
fproto    344
yes i have tried both.
disabling z would make it less although still messed up.
and i don't know why i would have to sort it.
when i worked with beginner tutorials when i was just starting out on directx,
i never had to sort anything. and it worked fine.

any other suggestions? thanks.

Share this post


Link to post
Share on other sites
fproto    344
well with backface culling, it only shows the front faces.
with frontface culling, it only shows the back faces.
and i would like to see both. that's why i'm using blending.

Share this post


Link to post
Share on other sites
Guest Anonymous Poster   
Guest Anonymous Poster
It will look better (cheap man's sorting, not perfect but good) if you:

1 Set backface culling to only show the back faces
2 Draw the object
3 Set backface culling to only show the front faces
4 Draw the object again

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this