Jump to content
  • Advertisement
Sign in to follow this  
helix

VS.NET -- IDE UI bug. Any workarounds?

This topic is 5007 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I guess this is the most logical forum to post this question in. It's not a programming question but rather a problem with visual studio .net (C++). When you have source files open in the editor, there is a tabbed list of them above the workspace. When you start debugging, a new list of the tabs is there in place of the original one (usually pretty close to the same list). Now my problem is that after every SINGLE time I use the debugger (actually use it -- like stepping into files, etc), my original list of file tabs is all messed up. It's like it's a hybrid of my original list and the debugging list. This is immensely annoying and I'm wondering if there is any known workaround for it. A friend told me he thought there was a setting somewhere that would disable the second debugging list but I can't find it anywhere. At the very least, am I the only one with this problem? I'm a very anal person and it drives me nuts to have my very specific and deliberate ordered list of files trashed like this every time I debug my game.

Share this post


Link to post
Share on other sites
Advertisement
I've never seen that. I'm not sure I've even seen this second list in debug mode. Far as I remember it's always been the same list. I switch back to MDI views anyway, so I just may not remember. 7.0 or 7.1?

Share this post


Link to post
Share on other sites
I've never noticed this. The list of files is always correct for me:)

Sorry, sounds like it could be isolated to your machine:)

Cheers
Chris

Share this post


Link to post
Share on other sites
I'm using version 7.1.3088. There's gotta be a setting somewhere to turn that off since you guys aren't haveing any problems. I can't take it any more!! :)

Share this post


Link to post
Share on other sites
Guest Anonymous Poster
It's not just your machine, and it drives me nucking futz as well.

Share this post


Link to post
Share on other sites
I'm glad that I'm not the only one then. :)

Well, I did some searching and I found the setting to switch it to the standard MDI instead of tabs but there's no way I can go back to that after using the tabs -- even if they do piss me off. I can't find any mention of separate tab lists anywhere in VS.NET or the internet. :(

I guess the obvious solution is to just never debug. Problem solved. (not like I ever code any bugs anyway) LOL!

Share this post


Link to post
Share on other sites
Ah that could be the issue, I don't use the tabs, i find they take up too much space for too little gain.

Cheers
CHris

Share this post


Link to post
Share on other sites
I use tabs and I've never had any weird problems like that. For me, the two lists are the same. Sometimes that causes slight inconvenience when I accidentally step into the STL and it opens 10 headers or something like that, but the files I had open before always stay open

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!