Jump to content
  • Advertisement
Sign in to follow this  
codehunter13

Direct3d9 debug errors

This topic is 4833 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi all, my textures are working but i get the folowing debug errors from directX: Direct3D9: (INFO) :Direct3D9 Debug Runtime selected. Direct3D9: :Device doesn't support mip-maps Direct3D9: (ERROR) :HAL Disabled: Device doesn't support texturing Direct3D9: :Device doesn't support mip-maps Direct3D9: (ERROR) :HAL Disabled: Device doesn't support texturing Direct3D9: (ERROR) :HAL Disabled: Device doesn't support texturing D3D9 Helper: Enhanced D3DDebugging disabled; Application was not compiled with D3D_DEBUG_INFO Direct3D9: (INFO) :======================= Hal HWVP device selected Direct3D9: (INFO) :HalDevice Driver style 9 Direct3D9: :BackBufferCount not specified, considered default 1 Direct3D9: :DoneExclusiveMode Direct3D9: (WARN) :Ignoring redundant SetTextureStageState. Stage: 0, State: 2 i've got a Geforce fx 5200 (Asus). does sombody have a clue? thx in advance

Share this post


Link to post
Share on other sites
Advertisement
Quote:
Direct3D9: (ERROR) :HAL Disabled: Device doesn't support texturing

Go into the DX Diagnostics tool (Start->Run->"dxdiag") and check the "Display" tab. I'm guessing that in the middle it'll have "Direct3D Acceleration: Disabled".

Quite likely that you've got a screwed up install of DirectX and/or Drivers. Reinstall both if the above trick doesn't work.

Given how basic a feature texturing is, it's most probably not able to use your hardware properly.

Quote:
D3D9 Helper: Enhanced D3DDebugging disabled; Application was not compiled with D3D_DEBUG_INFO

put the line #define D3D_DEBUG_INFO before you #include<d3dx9.h> if you want more information. This is optional and you don't really need to worry about it!

Quote:
Direct3D9: :BackBufferCount not specified, considered default 1

You haven't specified the D3DPRESENT_PARAMETERS::BackBufferCount field before creating your device. '1' indicates standard double buffering, so won't cause you any problems.

hth
Jack

Share this post


Link to post
Share on other sites
thx for the fast responses.
my drivers are up to date and Direct3D Acceleration is enabled for my secondary videocard(the fx5200). my primary doesn't support that.
But i'm using the second in my prog.

Share this post


Link to post
Share on other sites
Quote:
Original post by codehunter13
thx for the fast responses.
my drivers are up to date and Direct3D Acceleration is enabled for my secondary videocard(the fx5200). my primary doesn't support that.
But i'm using the second in my prog.

Given that you say your textures are working, and you're sure your software isn't a problem I'd be assuming that the debug spew you're seeing is with respect to your primary adapter

It's not identifying which adapter it's complaining about, but it is quite possible that as part of D3D's initialization it's looking at the default adapter before it goes on to create your actual device from the adapter you want.

Bottom line - if everything appears to be working, ignore those messages [smile].

hth
Jack

Share this post


Link to post
Share on other sites
Quote:
Original post by codehunter13
mm that's what i was thinking. when i have some time i'm gonna remove the primary card and test it again.

You might be able to get away with just disabling the primary device using the windows device manager in the control panel. Saves the hassle of pulling bits out of your box [smile]

hth
Jack

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

Participate in the game development conversation and more when you create an account on GameDev.net!

Sign me up!