Jump to content
  • Advertisement
Sign in to follow this  
iedoc

still errors

This topic is 5007 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

im still getting errors when i try to execute nehe's lesson. i don't get them when i execute the executable, but when i try to compile, then execute from c++ i get some errors, whats the deal?

Share this post


Link to post
Share on other sites
Advertisement
if smart_idiot's reply doesn't solve your problem, then please post a list of the errors you are getting and the steps you are using to setup and compile the program. This will help everyone find a solution for you.

Thanks!

Share this post


Link to post
Share on other sites
it compiles just fine, but when i execute it, it has errors, the kind you get when your missing a lib or something

--------------------Configuration: lesson8 - Win32 Debug--------------------
Linking...
lesson8.obj : error LNK2001: unresolved external symbol _auxDIBImageLoadA
lesson8.obj : error LNK2001: unresolved external symbol _gluBuild2DMipmaps
lesson8.obj : error LNK2001: unresolved external symbol _glTexImage2D
lesson8.obj : error LNK2001: unresolved external symbol _glTexParameteri
lesson8.obj : error LNK2001: unresolved external symbol _glBindTexture
lesson8.obj : error LNK2001: unresolved external symbol _glGenTextures
lesson8.obj : error LNK2001: unresolved external symbol _gluPerspective
lesson8.obj : error LNK2001: unresolved external symbol _glLoadIdentity
lesson8.obj : error LNK2001: unresolved external symbol _glMatrixMode
lesson8.obj : error LNK2001: unresolved external symbol _glViewport
lesson8.obj : error LNK2001: unresolved external symbol _glBlendFunc
lesson8.obj : error LNK2001: unresolved external symbol _glColor4f
lesson8.obj : error LNK2001: unresolved external symbol _glLightfv
lesson8.obj : error LNK2001: unresolved external symbol _glHint
lesson8.obj : error LNK2001: unresolved external symbol _glDepthFunc
lesson8.obj : error LNK2001: unresolved external symbol _glClearDepth
lesson8.obj : error LNK2001: unresolved external symbol _glClearColor
lesson8.obj : error LNK2001: unresolved external symbol _glShadeModel
lesson8.obj : error LNK2001: unresolved external symbol _glEnable
lesson8.obj : error LNK2001: unresolved external symbol _glEnd
lesson8.obj : error LNK2001: unresolved external symbol _glVertex3f
lesson8.obj : error LNK2001: unresolved external symbol _glTexCoord2f
lesson8.obj : error LNK2001: unresolved external symbol _glNormal3f
lesson8.obj : error LNK2001: unresolved external symbol _glBegin
lesson8.obj : error LNK2001: unresolved external symbol _glRotatef
lesson8.obj : error LNK2001: unresolved external symbol _glTranslatef
lesson8.obj : error LNK2001: unresolved external symbol _glClear
lesson8.obj : error LNK2001: unresolved external symbol _glDisable
Debug/lesson8.exe : fatal error LNK1120: 28 unresolved externals
Error executing link.exe.

lesson8.exe - 29 error(s), 0 warning(s)

Share this post


Link to post
Share on other sites
so it compiles but does not link properly?
It links when i compile (VC++.net2003).

If you are _sure_ the libs are in the right directory, try using directives to make sure the build links the correct libs. Paste these at the top of the lesson8.cpp file:

#pragma comment(lib, "opengl32.lib")
#pragma comment(lib, "glu32.lib")
#pragma comment(lib, "glaux.lib")

The fact its not getting any "LNK1104: File not Found" Errors says to be that the link isn't told to link those libs rather than the libs not existing in the right directory.

Share this post


Link to post
Share on other sites
it used to work, but i had to reinstall my computer, and now it doesn't. i have all the files, but i think maybe there wrong or something. do you think you could give me a website that has the correct libs?

Share this post


Link to post
Share on other sites
Did you try setting the paths in MSVC (I haven't used it in a while but I think they're located in the Options dialog box somewhere). Anyone who does use it frequently please fill in here (there should be a tab called 'Directories' IIRC)...

On second thought, those are the OpenGL libs so that shouldn't be a problem...

Hope it helps and good luck!

Share this post


Link to post
Share on other sites
ok, i think i know what the problem is. i didn't put my opengl drivers anywhere. does anybody know where to put them?

Share this post


Link to post
Share on other sites
yesss!!! i got it to work, but i have to have the dll's in the directory where the cpp file is. where should i put the dll's so i don't have to keep copying and pasting?

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!