Sign in to follow this  

module_path with GTK 1.x.

This topic is 4666 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

So, after installing mplayer (with the gui option enabled), and toying around so that my normal user was in the video group so I could play videos and such without having to be root, I've run into a problem again that I THOUGHT I fixed. It goes as follows: The error started as such:
bash-3.00$ gmplayer
MPlayer 1.0pre6-3.3.4 (C) 2000-2004 MPlayer Team
CPU: Advanced Micro Devices Athlon MP/XP/XP-M Barton (Family: 6, Stepping: 0)
Detected cache-line size is 64 bytes
CPUflags:  MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx SSE

vo: X11 running at 1152x864 with depth 24 and 32 bpp (":0.0" => local display)

Gtk-WARNING **: Unable to locate loadable module in module_path: "libindustrial.so",
Now, I got the Industrial theme engine for GTK 2.x and 1.x, got that working for both 2.x and 1.x (or so I thought, it installed properly anyway). Now, I thought "gee, since I have it installed, it musn't warn me now!" However, I was wrong to think such nice things. The warning only went away when I edited /home/cmaple/.gtkrc-1.2-gnome2. However, every time I exit X for some reason, and come back in, the file goes back to normal! (I put the following line in the file [which says Do Not Edit at the top [razz]] module_path "/usr/local/lib/gtk/themes/engines" which made it work - temporarily.) There's also a similar file in my homedir except with a .save extension - I tried editing this - and even though it doesn't reset itself upon re-entering X - it doesn't really help. I'm assuming I edited the right/wrong file to begin with (right in that it fixed it for that session, wrong that it was reset by a program that controls it). If anybody knows where I could slap in module_path "/usr/local/lib/gtk/themes/engines" into a GTK 1.x config file, I would be very greatful - it doesn't prevent me from using any software, but it annoys me to no end. Thanks!

Share this post


Link to post
Share on other sites
Sign in to follow this