Sign in to follow this  

problem building juice framework

This topic is 4660 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

http://www.rawmaterialsoftware.com/juce/ it says i need the microsoft sdk but the only thing i can find is the platform sdk update which doesnt seem to include and library or include files, and when trying to build the app even with this installed i get the following errors was just wondering if someone would be able to help me please juce_SolidColourBrush.cpp c:\documents and settings\mike\my documents\uni\project\juce_1_7\juce\src\juce_appframework\gui\graphics\brushes\juce_solidcolourbrush.cpp(234) : warning C4405: 'mm5' : identifier is reserved word c:\documents and settings\mike\my documents\uni\project\juce_1_7\juce\src\juce_appframework\gui\graphics\brushes\juce_solidcolourbrush.cpp(234) : error C2400: inline assembler syntax error in 'opcode'; found 'mm5' c:\documents and settings\mike\my documents\uni\project\juce_1_7\juce\src\juce_appframework\gui\graphics\brushes\juce_solidcolourbrush.cpp(241) : warning C4405: 'mm0' : identifier is reserved word c:\documents and settings\mike\my documents\uni\project\juce_1_7\juce\src\juce_appframework\gui\graphics\brushes\juce_solidcolourbrush.cpp(241) : error C2400: inline assembler syntax error in 'opcode'; found 'mm0' c:\documents and settings\mike\my documents\uni\project\juce_1_7\juce\src\juce_appframework\gui\graphics\brushes\juce_solidcolourbrush.cpp(251) : error C2400: inline assembler syntax error in 'opcode'; found '[' c:\documents and settings\mike\my documents\uni\project\juce_1_7\juce\src\juce_appframework\gui\graphics\brushes\juce_solidcolourbrush.cpp(256) : error C2400: inline assembler syntax error in 'opcode'; found '[' juce_Colour.cpp c:\documents and settings\mike\my documents\uni\project\juce_1_7\juce\src\juce_appframework\gui\graphics\imaging\juce_image.cpp(470) : error C2400: inline assembler syntax error in 'opcode'; found '[' c:\documents and settings\mike\my documents\uni\project\juce_1_7\juce\build\win32\platform_specific_code\juce_win32_windowing.cpp(431) : error C2065: 'WS_EX_LAYERED' : undeclared identifier thanks alot

Share this post


Link to post
Share on other sites

This topic is 4660 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this