Sign in to follow this  

Release build error unresolved external symbol

This topic is 4664 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Im trying to release build my directx application but i get lots of unresolved external symbol errors during the linking process. if runs fine when i do a Debug build. Iam using Visual C++ .net 7.0 Is it because I am using the Debug version of the DirectX SDK. The release version of the SDK is supposed to be used for a release build i think.

Share this post


Link to post
Share on other sites
Allways post your actual error messages if you expect to get a useful answer.

If you're linking against the debug version of the SDK in release mode, that's probably your problem. It should be pretty easy to just try linking the release version in your release build, yes?

Share this post


Link to post
Share on other sites
If you get an unresolved external saying some function hasn't been defined, search in your documentation and it will tell you what library that function is defined in. Then you just make sure you're linking against the correct version of that library (debug/release, single/multithreaded, dll/static lib)

Share this post


Link to post
Share on other sites

This topic is 4664 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this