Sign in to follow this  

Proper palette handling in SDL

This topic is 4659 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Question: Whats the proper way to handle palettes in SDL? See, I'm doing this thing where I load a bunch of bitmaps (through various gzip and rwops methods) and then convert them to hardware surfaces, so I can copy rectangles off the bitmaps and onto the display surface. Now, the problem is the palette (which I also load through various xml means) loads fine, and all checks I've done into surface->format->palette->colors seems to match up, just they display all screwed up. The only thing I can guess is theres a color mismatch somewhere (even though they're all 8bit surfaces). Anyway, what I want to know is what the official and common sense proper way is to do this stuff. Also, I don't want anyone telling me not to use palettes.

Share this post


Link to post
Share on other sites

This topic is 4659 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this