Jump to content
  • Advertisement
Sign in to follow this  

unresolved externals (MSVC6)

This topic is 4815 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi, I'm having a strange error with MSVC6 and libjpeg. I keep getting 'unresolved external' function errors during the linking stage. These messages go away if I place the source code all in the same directory. Why is this occuring? Is there some kind of switch/option I am missing? (I've never had this happen before -- it appears to happen exclusively with libjpeg. If I try and copy the example code into a new directory and recompile I get link errors, move the file back into the original directory and everything works fine...) Thanks.

Share this post


Link to post
Share on other sites
Advertisement
Well I presume so, otherwise MSVC would complain that it could not find libjpeg (library), or headers (include). And if I 'click' on the files it takes me to the right source code,..

Is there anything else that I can do to check this?

Share this post


Link to post
Share on other sites
you may have the path to the library set up correctly, but it sounds like you're not trying to link to the jpeg library. Have a look at project properties->linker->command line. You should see libjpeg.lib in there. If it's not you'll need to link to it explicitly - in the linker->input tab, type the library name.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

Participate in the game development conversation and more when you create an account on GameDev.net!

Sign me up!