Jump to content
  • Advertisement
Sign in to follow this  
ade-the-heat

annoying 'bands' on textures

This topic is 4906 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

http://myweb.tiscali.co.uk/3drocknroll/bands.bmp the above pic shows annoying blue bands insted of a smooth blue sky. Its worse when on full screen mode. How do I fix it ? cheers Ade

Share this post


Link to post
Share on other sites
Advertisement
Did you save your texture as JPG?
Are you using texturing compression?
Did you save your texture in a low colour depth? (8 or 16 bit)

Share this post


Link to post
Share on other sites
Hi,
The tex is 24bit bitmap.
ie 8 bits for r, g and b.

In the pixel format descriptor in setting up the window I use the below:
ie color depth = 16 bit. I changed it to 24 bit but it made no difference.

===============
PIXELFORMATDESCRIPTOR pfd =

sizeof(PIXELFORMATDESCRIPTOR), // size
1, // version
PFD_SUPPORT_OPENGL |
PFD_DRAW_TO_WINDOW |
PFD_DOUBLEBUFFER, // support float-buffering
PFD_TYPE_RGBA, // color type
16, // prefered color depth
0, 0, 0, 0, 0, 0, // color bits (ignored)
0, // no alpha buffer
0, // alpha bits (ignored)
0, // no accumulation er
0, 0, 0, 0, // accum bits (ignored)
24, // depth buffer
0, // no stencil buffer
0, // no auxiliary buffers
PFD_MAIN_PLANE, // main layer
0, // reserved
0, 0, 0, // no layer,
};



Share this post


Link to post
Share on other sites
How are you loading it?


Also, that banding doesn't look much different from normal banding seen when lighting a simple texture. You only have so many shades of blue to go around...

Here is an example.

You can't really get around that, you can just try and make it less noticeable by making the sky texture a bit more complex... Like the texture on the walls in that pic, where there is no noticeable banding...

:D Just a guess... you probably aren't doing any lighting on that sky from the looks of your screenshot.

Share this post


Link to post
Share on other sites
16, // prefered color depth

Just as a hint, 16 is low, and 24 is becomeing unsupported in fullscreen mode, so it falls back to software, try 32bit, unless you have a 6 year old gfx card.

Share this post


Link to post
Share on other sites
I was having this exact problem and just happened upon your thread. It turns out I only getting banding issues with my skydome when I enabled texture compression (like Vampyre_Dark suggested). I no longer tell opengl to compress it (ie don't use GL_COMPRESSED_RGB), and the problem is fixed! Anyway, thanks for the timely post, and I hope this helps you.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!