Sign in to follow this  
Mari_p

Something seems to be limiting the Radeon 9600 performance

Recommended Posts

Mari_p    232
Hi, I'm testing the following computer configuration: - AMD Sempron 2.6 GHz - RAM - 512 Mb - Video card ATI Radeon 9600 Pro 256Mb (with the old drivers, from the card's CD) So, I ran a very simple Direct3D demo and got only 62 fps in all supported resolutions (640x480, ..., 1280x1024). However, I got 166 fps in 640x480 running this demo with the following configuration: - AMD Atlhon 2.4 GHz - RAM - 512 Mb - Video card Gforce4 MX (with the old drivers, from the card's CD) I know that Radeon 9600 Pro is faster than Gforce4 MX, so what would be the possible problem? Something seems to limit the Radeon performance... Note: - Vsync is OFF in both cases. - DirecX version: 9.0 Thanks in advance

Share this post


Link to post
Share on other sites
Evil Steve    2017
That definitely sounds like a vsync problem if the FPS is roughly the same in all modes.
Are you sure the drivers don't force v-sync? I know you can force v-sync on or off (or let the app decide) with the latest nVidia drivers (in "Performance & Quality Settings").

Share this post


Link to post
Share on other sites
Mari_p    232
Thank you for replying.

Quote:
Try running it in windowed mode.

humm... I didn't really test the demo in windowed mode. Unfortunately, the computer with the ATI card is at the office, so I will test later.

Quote:
Are you sure the drivers don't force v-sync?

I'm sure that the demo's code sets:

d3dpp.PresentationInterval = D3DPRESENT_INTERVAL_IMMEDIATE;

Is this not enough to guarantee that v-sync is off? I had never used a ATI card before... is there some setting in the video properties to force v-sync to be always on? (or some place where I could disable that)

Thanks again

Share this post


Link to post
Share on other sites
mdias    823
Quote:
Original post by Mari_p
...
I'm sure that the demo's code sets:

d3dpp.PresentationInterval = D3DPRESENT_INTERVAL_IMMEDIATE;

Is this not enough to guarantee that v-sync is off? I had never used a ATI card before... is there some setting in the video properties to force v-sync to be always on? (or some place where I could disable that)

Thanks again

It is if the drivers is configured to let the application decide, but the driver can be configured to force v-sync, so you might want to check that ;)

Share this post


Link to post
Share on other sites
Krisc    494
But wouldn't the VSYNC force it to be 60fps?

I don't think, with VSYNC on, it would be possible to hit 62 unless the refresh rate was at 80 and the frame rate was dropping below that...

Share this post


Link to post
Share on other sites
Evil Steve    2017
Quote:
Original post by Krisc
But wouldn't the VSYNC force it to be 60fps?

I don't think, with VSYNC on, it would be possible to hit 62 unless the refresh rate was at 80 and the frame rate was dropping below that...
It's probably a calculation error. If the refresh rate is > 60Hz, it's possible to get over 60FPS with V-sync enabled.
The reason I say it looks like a V-sync problem is that the FPS doesn't change when the resolution changes. So it's definitely not fillrate limited, and I very much doubt that it's vertex-throughput limited on a Radeon 9600.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this