Jump to content
  • Advertisement
Sign in to follow this  
xsirxx

Need some texture help? with addressing...

This topic is 4837 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I have my texture cordinates imported from 3dstudio on my models. Only problem is in 3dstudio, you can set the uv cords to 10.0 and 10.0 to make the texture to tile 10 times. When I import into directx it gives strange results. Is there a way to get them to tile 10 times by using this method? Or how should I convert them so directx can do this? Also I am using a shader to place textures and colors on the triangles... Should this be taken care of inside the shader (effect framework)? if so any ideas on how, or where I should lookup this info?
	m_pd3dDevice->SetSamplerState(0, D3DSAMP_ADDRESSU, D3DTADDRESS_WRAP);
	m_pd3dDevice->SetSamplerState(0, D3DSAMP_ADDRESSV, D3DTADDRESS_WRAP);
	m_pd3dDevice->SetSamplerState(0, D3DSAMP_ADDRESSW, D3DTADDRESS_WRAP);

like that for inside the shader? **Also, sorry I have been having BAD luck with the new search engine(google) on here. I always had such good results with the old one that is taken off. --Brad

Share this post


Link to post
Share on other sites
Advertisement
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

Participate in the game development conversation and more when you create an account on GameDev.net!

Sign me up!