Jump to content
  • Advertisement
Sign in to follow this  
PaulAtreus

SOLVED: Unable to display anything...

This topic is 4775 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I have just gone through and constructed a new base code from scratch. I got all the code to handle creating the window, displaying it fullscreen/windowed, handling user input, etc. However, now when I try to display any primitives, it's still just a black screen. Even in my initialization code, if I alter the glClearColor values it always clears to just a black screen. I have stepped through my code multiple times, have disected my code while using the Red Book looking for anything, and have even resorted to trying to copy+paste the Nehe basecode snippet from certain areas to replace my code, but still nothing. I can post my code if you'd like, but there is quite a bit of it, as it is the complete basecode for creating of the window, initialization, and handling input. Any help? edit: spelling (late night)

Share this post


Link to post
Share on other sites
Advertisement
Nevermind, I just realized I had made a mistake in the order of my initialization and had been making a few OpenGL calls before creating the window and that seemed to throw the whole thing off. But problem solved :)

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

Participate in the game development conversation and more when you create an account on GameDev.net!

Sign me up!