Jump to content
  • Advertisement
Sign in to follow this  

dev cpp compile error

This topic is 4754 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Advertisement
Guest Anonymous Poster
I got this error because I was using OpenAL, not because of DX. I was getting problems from my libalut.a. I don't remember where I downloaded this originally, but this one doesn't have the dependency that the one in the devpack has. I don't know if it breaks anything else, but it fixed the compiler problem for me.

http://www.geocities.com/greyrogue42/files/Libalut.zip

Share this post


Link to post
Share on other sites
MinGW (the compiler that comes with Dev-C++) doesn't care if it's a .a or a .lib library, just as long as it's of a specific format (if you haven't already noticed, the lib folder is full of .a libraries, but other libraries (OpenAL, ODE, etc.) all use .lib libraries).

As for the OpenAL ALut library, I'd ignore that (I had the same problem, easily solved by writing your own functions). The ALut functions are being deprecated in OpenAL 1.1, so if I was you, I'd be avoiding them anyway. ;)

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

Participate in the game development conversation and more when you create an account on GameDev.net!

Sign me up!