Jump to content
  • Advertisement
Sign in to follow this  
Mr Grinch

Crown and Cutlass Alpha 1.3 (Released fix for font issue)

This topic is 4899 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I'm a developer for Crown and Cutlass, a 3d pirate action/adventure game in the spirit of the old Pirates! game. It is written in C++, using OpenGL and SDL with an emphasis on cross-platform compatibility. We released Alpha 1.3 yesterday. You can download it here. This release is a pretty big step, although it does earn its 'alpha' designation. We have started our transition to Guichan for our GUI system. We wrote the old GUI system ourselves, and found that we were spending more time than we wanted working on that. Guichan seems like it will be a good fit. We also have a first shot a ship physics, improved enemy ship AI in battles, a skydome in battles (you have to use the 0-9 keys to see it, though). We also have some new art and music. Here are a few new screenshots: You can see other screenshots on our screenshots page. Let me know what you think, or if you have problems or suggestions for us. Thanks. [Edited by - Mr Grinch on May 22, 2005 10:27:37 AM]

Share this post


Link to post
Share on other sites
Advertisement
Hi, the executable wouldn't run. It does not do anything, not even an error.


Configuration:
Resolution: 1024 x 768
Fullscreen: false
Use VBOs: true
Enable SDL Parachute: false
Compress Textures: true
TicksBetweenBattles: 20000

Got video info
Video mode set
Warning: Your video card does not support VBOs, falling back on VAs
Extensions verified
Audio initialized
Current state pointer set
Font lists generated
Font texture loaded
Font texture bound
Fonts built

Share this post


Link to post
Share on other sites
Sorry about that, it seems that we are having some issues with the new menu system and one of the fonts we selected. The font image is over 2400 pixels wide (but not nearly as tall). Many (most maybe) people's video cards can only handle textures that are 2048x2048. We'll work it out with the guichan team. Until then, you can download and use another font texture from guichan here.

You can also see my post in our forums.

Talk about a frustrating release... sorry.

Share this post


Link to post
Share on other sites
Quote:
Original post by Mr Grinch
Sorry about that, it seems that we are having some issues with the new menu system and one of the fonts we selected. The font image is over 2400 pixels wide (but not nearly as tall). Many (most maybe) people's video cards can only handle textures that are 2048x2048. We'll work it out with the guichan team. Until then, you can download and use another font texture from guichan here.

You can also see my post in our forums.

Talk about a frustrating release... sorry.

Couldn't get it to work.. First I tried a different font, but the glyphs are in different order so I don't even know how that could have worked (and it didn't, whether that was the reason for it, I have no idea). Then I tried resizing, but that didn't work either.

So I guess I'll just have to wait for the next release.. :( Too bad, I was really looking forward to give this a try.

Share this post


Link to post
Share on other sites
I just released a fix for the font image issue. Please download Alpha 1.31 and copy those files into the Alpha 1.3 directory. Note that this just contains a few new files, so you need the complete Alpha 1.3 install for it to work. The other developer usually handles creating the windows binaries, so I hope I didn't screw it up! Let me know how it works for you. Thanks.

Share this post


Link to post
Share on other sites
I want to try this - I'm just not sure if I have to download all of those releases? Do I get the installer 1.30 and then 1.31?

Share this post


Link to post
Share on other sites
Sorry, I thought that would be clear, but I guess the patch files are kind of confusing. If you are compiling the source yourself, then you need the 1.3 tar.gz file, as well as the new 1.31 tar.gz patch (it has the new images). If you just want to use the windows installer, then you need the 1.3 msi installer, and the new 1.31 zip patch (it has the new images, new exe, and new dlls). Does that help?

Share this post


Link to post
Share on other sites
Ok, I had more problems: When I compiled the fixed 1.31 windows exe, I left a line I had for debugging that caused all the ships in a naval battle to just run away from you. It only affects the Alpha 1.31 .zip file that included the windows exe. If you downloaded it, please download it again. Sorry, I'm so embarrassed...

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!