• Advertisement
Sign in to follow this  

SDL troubles...

This topic is 4661 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

All right. So I downloaded SDL. I installed it to the directories. I got it working with VC++ 6.0 Introductory Edition. Then, I changed the compiler to VC++ Toolkit 2003 (I'm still using the same IDE, I just pointed it to the new compiler's directory) and I get these errors: SDLTest.obj : error LNK2001: unresolved external symbol __RTC_Shutdown SDLTest.obj : error LNK2001: unresolved external symbol __RTC_InitBase I must admit that I've never heard of these functions in my life! Can someone help me with this?

Share this post


Link to post
Share on other sites
Advertisement
What's the code you're using? It could also be because your forgetting to include all of the SDL libraries.

Share this post


Link to post
Share on other sites

#include "SDL.h"

int main( int argc, char* argv[] )
{
// Body of the program goes here.
return 0;
}





Straight out of the SDL manual. Just for a test. I'm linking both sdl.lib and sdlmain.lib. And I've tried them in different orders, too.

Share this post


Link to post
Share on other sites
Take a look at this page, which someone has the same problem you are having. The solution is in the post at the bottom, a few settings to change. See if those work for you. Good luck!

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement