Sign in to follow this  
TheSeb

errors at the compilation to create shader

Recommended Posts

Hi, i have written this : hvs = CreateShader(VERTEX_SHADER); and my errors are : error C2065: 'CreateShader' : undeclared identifier error C2065: 'VERTEX_SHADER' : undeclared identifier I have the latest drivers for my ATI card (it works perfectly with render monkey) can you help me ?

Share this post


Link to post
Share on other sites
You, uh, probably want to read this:

http://oss.sgi.com/projects/ogl-sample/registry/ARB/vertex_shader.txt

Have you just copied and pasted some code from the net? Cause unless you actually have functions called CreateShader, it's not gonna work.

There's good tutorials on CodeSampler.com: http://www.codesampler.com/oglsrc/oglsrc_10.htm#ogl_glslang_simple_vs2ps

and theres some on UltimateGameProgramming.com too.

Hopefully I was of some help...

Share this post


Link to post
Share on other sites
ok thanks !
in fact, i have seen this syntax in the opengl 2.0 specs and there the letters "gl" are missing. Otherwise i have used glew for that it works.

Share this post


Link to post
Share on other sites
The various OpenGL specs (formal and extension) drop the "gl" prefix as its redundant due to all OpenGL functions having the prefix, I belive this is covered at the top of the OpenGL spec.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this