Jump to content
  • Advertisement
Sign in to follow this  
BloodLust666

Ortho camera

This topic is 4747 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

i have an ortho camera (obviously) with a near plane of 0 and a far plane of 5, but when i place my background texture at anything with a Z value past 1 it doesn't show up, it only shows when i place it exactly at 1.

Share this post


Link to post
Share on other sites
Advertisement
Why do you have a far plane of 5...
normally it would be 1.0f, and 1000.0f
I assume that this plane is outside of the boundaries .. but i'll have to check.
Give us some more information

Share this post


Link to post
Share on other sites
oh sry, i'm doing a 2d game, and i'm using about layers of textures (i'm only using 2 right now the background and the sprites). but when i have the background at >2, the background doesn't show up.

Share this post


Link to post
Share on other sites
I'm not sure if it's releated to the missing objects, but you should have your near clipping plane at 1.0f. Anything else is not optimized and can cause bad z-fighting. It may even be the cause of the missing objects...

Matt Hughson

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

Participate in the game development conversation and more when you create an account on GameDev.net!

Sign me up!