Jump to content
  • Advertisement
Sign in to follow this  
ragdev

[web] AspDotNet module for apache

This topic is 4786 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi! I've been trying to set up aspx on my machine but on aspx files it returns Internal Server, even if its just a file with html conde, and .asp files show plain text. I have apache 2.0.54, with mod_aspdotnet-2.0.0 the conf file:
LoadModule aspdotnet_module modules/mod_aspdotnet.so

AddHandler asp.net asax ascx ashx asmx aspx axd config cs csproj licx rem resources resx soap vb vbproj vsdisco webinfo

<IfModule mod_aspdotnet.cpp> 
AliasMatch "^/(?i)aspnet_client/system_web/(\d+)_(\d+)_(\d+)_(\d+)/(.*)"  "C:/Windows/Microsoft.NET/Framework/v$1.$2.$3/ASP.NETClientFiles/$4"
 
 
<Directory "C:/Windows/Microsoft.NET/Framework/v*/ASP.NETClientFiles">
    Options FollowSymlinks
    Order allow,deny
    Allow from all
</Directory>
 
AspNetMount /net "C:/somedir"
Alias /net "C:/somedir/asp"
<Directory "C:/somedir/asp">
    Options FollowSymlinks Indexes Includes ExecCGI
    Order allow,deny
    Allow from all
    DirectoryIndex default.htm default.aspx
</Directory>

</IfModule>



Am I missing something? I've read the mod faq and this should be working... Thanks :)

Share this post


Link to post
Share on other sites
Advertisement
Ok I figured it out :x

instead of:
AspNetMount /net "C:/somedir"
Alias /net "C:/somedir/asp"

I should have:

AspNetMount /asp "C:/somedir"
Alias /asp "C:/somedir/asp"

hope it helps someone :x

Share this post


Link to post
Share on other sites
paulecoyote ;)

Well I'm back again and I've noticed a typo in my previous post :S

It should be:

<IfModule mod_aspdotnet.cpp>

AspNetMount /aspx "C:/somedir/aspx"
Alias /aspx "C:/somedir/aspx"

<Directory "C:/somedir/aspx">
Options FollowSymlinks ExecCGI
Order allow,deny
Allow from all
DirectoryIndex Default.htm Default.aspx
</Directory>

# For all virtual ASP.NET webs, we need the aspnet_client files
# to serve the client-side helper scripts.
AliasMatch /aspnet_client/system_web/(\d+)_(\d+)_(\d+)_(\d+)/(.*) "C:/Windows/Microsoft.NET/Framework/v$1.$2.$3/ASP.NETClientFiles/$4"
<Directory "C:/Windows/Microsoft.NET/Framework/v*/ASP.NETClientFiles">
Options FollowSymlinks
Order allow,deny
Allow from all
</Directory>

</IfModule>

Otherwise apache will go nuts and spits a 500 internal server error! :X

Anyway, for the last couple of weeks I've been trying to understand why my .aspx files come in plain text. I've been googling but until now I could't find an answer to this.. :(

Also VS.NET throws an error when I try to create/open a asp.net web app:
"Visual Studio .NET has detected that the specified Web server is not running ASP.NET version 1.1. You will be unable to run ASP.NET Web applications or services."
I tryed the workaround on http://support.microsoft.com/default.aspx?scid=kb;en-us;825792 but no luck either... :I think I'm missing something but I have no idea what it is.

Any ideas?
Thanks :)

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!