Jump to content
  • Advertisement
Sign in to follow this  
moagstar

Strange Link Error

This topic is 4792 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi, When I compile my project in debug mode it works fine, but when I try to compile in Release mode I get the following strange error : LINK : error : Internal error during ReadSymbolTable ExceptionCode = C0000005 ExceptionFlags = 00000000 ExceptionAddress = 00465407 NumberParameters = 00000002 ExceptionInformation[ 0] = 00000000 ExceptionInformation[ 1] = 00000068 CONTEXT: Eax = 01C30FC0 Esp = 0012F614 Ebx = 00000000 Ebp = 004A2888 Ecx = 00000000 Esi = 01C500FC Edx = 00000001 Edi = 004A2B38 Eip = 00465407 EFlags = 00010202 SegCs = 0000001B SegDs = 00000023 SegSs = 00000023 SegEs = 00000023 SegFs = 00000038 SegGs = 00000000 Dr0 = 0012F614 Dr3 = 00000000 Dr1 = 004A2888 Dr6 = 00000000 Dr2 = 00000000 Dr7 = 00000000 Error executing link.exe. Tool execution canceled by user. I have no idea what is causing the error, or even what it means, does anyone know what it means, or how it can be fixed? Many Thanks EDIT : I am using VC++ 6.0

Share this post


Link to post
Share on other sites
Advertisement
Thanks for the suggestion but I've tried that, I even tried creating a new project and copying all the old files over but I still get the same error!

Share this post


Link to post
Share on other sites
Guest Anonymous Poster
this, found on google, might be of some use to you if you haven't seen it already
http://www.msusenet.com/history/topic.php/2637573-1.html

Share this post


Link to post
Share on other sites
Guest Anonymous Poster
seeing as there are only about 24 entries for that on google, if must be quite a rare problem. So if that is what the problem was I'm curious to know how freaking big was the file????

Share this post


Link to post
Share on other sites
Yeah that was the problem, it was pretty big, it's something that I'm knocking up that really needs to be split into smaller classes, but I want to get it working first. It's strange though because I'm sure I have had larger source files in the past and they have compiled fine! Anyway thanks for pointing me in the right direction.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!