Jump to content
  • Advertisement
Sign in to follow this  
JohnnyCasil

Strange Error

This topic is 4735 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Recently Visual Studio has been acting wierd. I have been working on a game engine for sometime now, and everything code wise is going fine... unfortunately, now I have a problem with the linker. I keep getting this error: LINK : LNK6004: ../../Debug/ArchD3D.dll not found or not built by the last incremental link; performing full link Creating library ../../Debug/ArchD3D.lib and object ../../Debug/ArchD3D.exp My solution is composed of 3 projects. A Static lib which always compiles fine, a Win32 app which gets the linker error, and a DLL that gets the linker error as well. I tried googling but I can't seem to find a definitive answer. I have also tried MSDN, but I can't find anything about the linker error. Does anyone have any insight into this.

Share this post


Link to post
Share on other sites
Advertisement
I'd guess the problem is that neither the exe nor the dll are looking in the right place for the library file. They're probably using the default library search paths, and either not finding it or finding an old, out of date version that you may have copied there to fix a previous link error.

Go to Project->Properties->Linker->General->Additional Library Directories and make sure that you have a suitable path to a folder containing an appropriate build (debug or release) of the library file.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

Participate in the game development conversation and more when you create an account on GameDev.net!

Sign me up!