Jump to content
  • Advertisement
Sign in to follow this  
Nokturnal

Tricks of the Windows Game Programming Gurus [ 2nd Edition]

This topic is 4822 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

hi I am a new member here , so greetings to you all :D i got this book from a friend , unfortunately he had got it from some other friend .....yada yada yada .....bottom line , i dont have the disk which has the SDK , since the book uses some direct draw , which is not there in some versions ( i am not aware of them) but which version of Dx Sdk should i install , DX 7 Or Dx 8 ?? And another question being , will installing a old sdk ie 7/8 , mess with the dx 9 which i ve currently running on my system ? Thanks

Share this post


Link to post
Share on other sites
Advertisement
Well i think that book uses DX 8, so i guess you should probably install the DX8 SDK if u want to follow thru Lamothe's examples. Installing an older DX *SDK* will not have any effect on the DX 9 (or later) *Runtime* so don't worry about that.

Hope i helped

Share this post


Link to post
Share on other sites
thanks , dipperdan - that does help me , i ll download the 8 sdk and install it.
wow .....CTar , thanks a million man :)

i guess i ll get started on the downloads :P

just another question , i made a brave move and already installed Dx9 Sdk ,
after uninstalling , this wont mess with the Dx 8 sdk , will it ?

man i hate formatting :(

Share this post


Link to post
Share on other sites
you should be able to use the dx9 std with the book. to the best of my knowledge, they are backwards compatble.

Share this post


Link to post
Share on other sites
Quote:
Original post by Nokturnal
hi
I am a new member here , so greetings to you all :D

i got this book from a friend , unfortunately he had got it from some other friend .....yada yada yada .....bottom line , i dont have the disk which has the SDK , since the book uses some direct draw , which is not there in some versions ( i am not aware of them) but which version of Dx Sdk should i install , DX 7 Or Dx 8 ??

And another question being , will installing a old sdk ie 7/8 , mess with the
dx 9 which i ve currently running on my system ?


Thanks

2nd edition, and the firts one two uses is written using DirectDraw7 (U only need DirectX 7 SDK). But if U want using DirectInput8, sound and other (8th ver is in the book) U must have DirectX 8 SDK.
Advice: try developing your apps in Direct3D. The book "Game Programming All In One" must help U.

Share this post


Link to post
Share on other sites
@Fish Fishes : i ll check that book out for sure :)

i d like to deviate from this topic and ask you guys a compiler related question .

Well the book involves everything using Dx8 Sdk , and the Vc++ 6.0 compiler which i have has a another version of library's . Even though if i add files manually
to the project ie from the include folder of the sdk , it ends up linking to the default includes with vc 6.0 , well one solution i figured out is to overwrite the files with the ones from the sdk , is there any other way how this can be achived ??
ie , is there some option in vc++ to set the compiler include path so that it looks for the sdk path first then looks into its original directory.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!