Jump to content
  • Advertisement
Sign in to follow this  
Aph3x

DirectInput debugging response delays

This topic is 4727 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi all, I'm having problems with severe mouse/key lag when debugging with DirectInput on Win2k. The problem is outlined here on MSDN, but the solution there makes no difference to the problem. I get no option for a debug install with the SDK, and I don't even have a DirectX control panel icon or the specified file where they say it should be!! Anyone any ideas?!

Share this post


Link to post
Share on other sites
Advertisement
Quote:
Original post by Aph3x
I get no option for a debug install with the SDK, and I don't even have a DirectX control panel icon or the specified file where they say it should be!!


Did you download the SDK from the http://msdn.microsoft.com/directx site or somewhere else?

Every version of the SDK I've ever used has had an option to install the "Debug Runtime" or "Developer Runtime".


Not having a DirectX control panel icon is usually an indication of:

- not installing the DirectX SDK (DirectX end user runtimes + headers & libs from the Platform SDK != DirectX SDK)

- the DirectX SDK is installed, but a newer version of the DirectX end user runtime has been installed over the top (e.g. you have an SDK which includes the DirectX 9.0b debug and retail runtimes, and you [or some software] has installed the DirectX 9.0c end user [retail] runtime).

- the DirectX SDK installation has failed in some way - not uninstalling older SDKs before installing new SDKs can cause problems.

[you may need to switch the control panel to "classic" mode under Win XP to see the icon]


The DirectInput debug stuff requires the debug runtime to be active...

Share this post


Link to post
Share on other sites
Hmm this is most annoying.
The SDK I have was from MS dx download centre: dx9sdkcp.exe (99 Meg)
I uninstalled totally and reinstalled - not a mention of debug stuff, and no DX control panel icon.
Maybe this is a terminology problem - is there another component aside from the SDK and the end user runtimes (distributables?)? Is it the 34MB directx_9c_redist.exe I need, or something else?! The dir structure doesn't even match that described in the readme!! Argh!

I cant get the latest SDK as it doesn't work with win2k apparently :(

[ed] Ah, found a 'developer runtime' on msdn, getting it now...

Share this post


Link to post
Share on other sites
Quote:
Original post by Aph3x
I cant get the latest SDK as it doesn't work with win2k apparently :(


"doesn't work" != "not supported".

The latest SDK is not supported on win2k, but it does work on win2k.

Share this post


Link to post
Share on other sites
Ah, true.

Well, installing the 'developer runtime' didn't help much either.

Now trying the full 240MEG sdk download... :rolleyes:

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

Participate in the game development conversation and more when you create an account on GameDev.net!

Sign me up!