Jump to content
  • Advertisement
Sign in to follow this  

Why can't I get the ATI driver to work =(

This topic is 4720 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I have recently installed the latest ati driver with graphical interface and so on =P. I configured it with fglrxconfig and answered the questions. Well I thought it should work properly now but when I restarted Debian it was like the same, I tested some games like tux-racer and it was like before, lagging as hell. What am I doing wrong? I tested to write cat /var/log/XFree86.0.log | grep EE and this went up: (WW) warning, (EE) error, (NI) not implemented, (??) unknown. (II) Loading extension MIT-SCREEN-SAVER (EE) fglrx(0): DRIScreenInit failed! I tested to write cat /var/log/XFree86.0.log | grep WW and this went up: (WW) fglrx(0): *********************************************** (WW) fglrx(0): * DRI initialization failed! * (WW) fglrx(0): * (maybe driver kernel module missing or bad) * (WW) fglrx(0): * 2D acceleraton available (MMIO) * (WW) fglrx(0): * no 3D acceleration available * (WW) fglrx(0): ********************************************* * I tested to set the Option UseInternalAGPGART to no, and rebooted, it was the same. Well as I see on the message "(maybe driver kernel module missing or bad)" i maybe should download a new kernel module, but when I tried to update my apt through apt-get update it went up errors. Well I want to know why the ATI driver not want to work and if it is kernel module that is wrong, how do I then update apt? It maybe should be useful if I say that my OS is Debian.

Share this post


Link to post
Share on other sites
Advertisement
Which drivers did you install? You might also want to check the output of lsmod to see if the fglrx module is being loaded correctly.

I have a working 9500, I used this guide to install the drivers: ATI Linux driver packages for Debian. It involves some work but I've managed to get two ATI cards working using that guide.

Share this post


Link to post
Share on other sites
Quote:
Original post by Aly
Which drivers did you install? You might also want to check the output of lsmod to see if the fglrx module is being loaded correctly.

I have a working 9500, I used this guide to install the drivers: ATI Linux driver packages for Debian. It involves some work but I've managed to get two ATI cards working using that guide.


Ah thanks, but why should it be so much problem to install fglrx driver? I used the latest ati driver "ATI Driver Installer 8.14.13"

Share this post


Link to post
Share on other sites
Lol the ATi installer. I just installed the RPM and configured it. Try recompiling your kernel with AGP/DRI support to see if it helps (useful, I know).

ATi's never been good with Linux support (it's gone up marginally in the past half a year or so), so don't expect any miracles. Once you do get it to work you can expect a lot of crashing.

Hope it helps!

Share this post


Link to post
Share on other sites
Quote:
Original post by fyhuang
Lol the ATi installer. I just installed the RPM and configured it. Try recompiling your kernel with AGP/DRI support to see if it helps (useful, I know).


You don't want to compile it into the kernel, you might want to compile modules for separate use otherwise it will conflict with the ATI driver. The DRI drivers will get 2d working but you're looking for 3d support which that page says stops at the r9250.

Quote:
Original post by fyhuang
ATi's never been good with Linux support (it's gone up marginally in the past half a year or so), so don't expect any miracles. Once you do get it to work you can expect a lot of crashing.


I'll second that, when I was using the vertex and fragment program extensions in OpenGL I quickly got tired of ATI's drivers and bought an nVidia card (and that was pretty straightforward to install).

Share this post


Link to post
Share on other sites
Ugh, I remember that. I wrote up a pretty nice and quick guide for Slackware some time ago, but unfortunately that's long gone. At least the drivers work ... except with an ATi Radeon X800 XL. That's the only damn chip they don't support in the newer cards.

Just keep trying, trust me, you'll eventually figure out the nuances of that picky little driver.

EDIT - I always just used the modules for both fglrx and agpgart, for reference.

Share this post


Link to post
Share on other sites
Guest Anonymous Poster
Well, it's though but I firgure it out... some day. Well, I can always change to NVIDIA card =P

Share this post


Link to post
Share on other sites
I don't think I will ever buy an ATI again... so poor support for linux it's ridiculous. Maybe they're nice cards, and can push out just as much, or better, performance that nVidia, but I've had more problems w/ linux+ati than I've ever had w/ linux+nvidia.

Windows, no complaints... I use the omega drivers, as they work better w/ the particular hardware setup I have, but really no complaints. Just with linux.


I've actually found it the easiest to install the linux ati drivers on the Gentoo distro. But I guess, I'm still a pseudo-newb, and really have not idea what I'm talking about... so I'll just go back to my corner and hide for awhile...

Share this post


Link to post
Share on other sites
It's usually easiest to install the ATi drivers on a non-specific distro. Meaning, a distro that isn't completely altered from the rest of the distros out there. Slackware is a prime example, and as it is the most Unix like of all the Linux distros, it's usually pretty straight forward. The dependency checking in Debian is wonderful, however, but I still have a soft spot for the ol' Slack.

Just a thought, did you enable the tmpfs that the drivers require? Also, I can't remember if enabling or disabling DRI helped. Actually, I'm pretty sure I had to enable DRI support in the kernel, on second thought.

Hmmm... I have an idea, I'll be back shortly.

Share this post


Link to post
Share on other sites
I'm back, with gifts! Here's the guide I wrote up some time ago for Slackware 10.1.

This is for Slackware 10.1, other systems are similar, but check the docs to
be sure.

CAUTION - The $ before each command in this mini-tut are representing the bash
prompt, do not enter them in along with the command.

NOTE - You will have to have DRI enabled in the kernel for ATi Radeon cards
for this to work "really" well. Also, if you have an nforce2 mobo, for
example, or one of the supported chipsets, enable agpgart as a module for your
specific chipset.

Frist, su to root, then install the package:

$ installpkg /where/ever/it/is/ati-blahblah.tgz

After a few seconds, or a minute, depending on the speed of your computer, you
will be prompted with the fglrxconfig menu. Fill in what is needed, and when
it prompts you to save to xorg.conf say y to confirm.

NOTE - When it prompts you for your mouse, simply type /dev/mouse, if not, the
X server will hang upon loading, and possibly freeze your system with lots of
nasty complaints in the X.org.log file.

Then, check over your xorg.conf file, and make sure everything is ok like the
setup program suggested.

NOTE - If you are using a nforce2 mobo, for example, you will want to say y to
using the external agpgart module during the setup process.

Then, simply type this:

$ startx

And, after a few seconds and a bit of hard drive churning, X should happily
pop up.

TIP - To change your current window manager, simply type this in a terminal:

$ xwmconfig

and choose from the range of WM's provided, and press enter. Restart X (ctrl+alt+backspace, startx), and enjoy!

Now, to let 3D apps run properly, you will have to do the following:

Open up /etc/fstab with your favourite editor:

$ nano /etc/fstab

And enter this into the file in its own line, seperating each word and number
like the other entries (not necessary, but makes for easier reading):

tmpfs /dev/shm tmpfs defaults 0 0

Then, save and exit, and enter super user mode (type su on a terminal), and
type the following into a terminal:

$ mount /dev/shm

Then, to check if all is well, type the following:

$ mount | grep "shm"

If the output is the following, or similar, then you've done it:

tmpfs on /dev/shm type tmpfs (rw)

I really hope that helps!

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

Participate in the game development conversation and more when you create an account on GameDev.net!

Sign me up!