Jump to content
  • Advertisement
Sign in to follow this  
BradDaBug

ODE and trimesh collisions not working

This topic is 4814 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I can't get trimesh collisions to work right. I've got my terrain set up as a bunch of blocks, and each block is a trimesh. Then I'm dropping some spheres onto the landscape. What's happening is that the spheres are going right through the landscape, and only collide on the underside of the terrain. I'm sending the same normals that I'm using to draw the terrain to ODE, and it still doesn't work when I reverse the normals. How do I get ODE to collide with the OTHER side of the trimeshes?

Share this post


Link to post
Share on other sites
Advertisement
Well, I guess I fixed it. ODE expects trimeshes to be CCW wound, not CW wound. I reversed the windings and it worked, but now I've got to reverse the windings of everything in my engine.

Moral: If you're planning on using ODE trimeshes, be sure you use CCW instead of CW windings!

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!