Jump to content
  • Advertisement
Sign in to follow this  
Yamian

Installing Nvida drivers in SuSE 9.1

This topic is 4858 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

How do I install the Nvidia drivers in SuSE 9.1? In the special instructions it says to use YOU, and I do exactly what it says, but none of my settings are different and it still says 3D Accelerator: Unavailable. What do I do? I'm using a GeForce FX 5500.

Share this post


Link to post
Share on other sites
Advertisement
I haven't used SuSE so don't take my word on this, but this is how you install nvidias drivers on linux:

1. Go here and download the latest drivers. Should be named NVIDIA-Linux-x86-1.0-7664-pkg1.run.

2. Make it executable if it isn't so by doing chmod +x NVIDIA-Linux-x86-1.0-7664-pkg1.run

3. Edit /etc/inittab and set the default runlevel to 3, and restart your computer. This tells linux to start in textmode, since you're going to tinker with the graphicdrivers.

4. If you're lucky you can run it by doing ./NVIDIA-Linux-x86-1.0-7664-pkg1.run and it asks if you want to download a precompiled package from the net. This doesn't work for me (I'm using Slackware) so maybe you have to compile it on your own. If so, continue to 5. Otherwise you can skip five.

5. Make sure that the kernel headers are installed. You should have some package for this I guess. Tell the installer that you don't want to fetch something from the net, and let it compile it for you.

6. Edit the X file. Depending on what you have it's called xorg.conf or XF86Config and you should find it in /etc/X11/. Scroll down until you find the graphics section. You should see a section named Device which has an attribute called Driver. This is probably set to vesa or nv or something. Change this to nvidia, and then you're ready to go! Edit /etc/inittab again and change the runlevel to 4 and restart the computer. Though you might want to try startx first to make sure it works. Then you should have 3d-acceleration!

And now that I've written all this I notice there is a special readme for suse users here. But you've read them already, right?

Anyway, this got rather lengthy, but I hope it helps you. Ask if you get any trouble.

Share this post


Link to post
Share on other sites
Well i reset the computer, should that do it or do I have to don something else.

Perost, if you look at that page, there are specific instructions for SuSE.

Share this post


Link to post
Share on other sites
Yes, I saw those instructions. But if they don't help, maybe my instructions can help you. Have you looked at you X config file like I say in point 6? It is very important that you X config file is correctly setup. Maybe you've got some graphical tool to change this with, but as I said I haven't SuSE. My instructions should work with just about any linux distribution though.

Share this post


Link to post
Share on other sites
Quote:
Original post by Perost
I haven't used SuSE so don't take my word on this, but this is how you install nvidias drivers on linux:

1. Go here and download the latest drivers. Should be named NVIDIA-Linux-x86-1.0-7664-pkg1.run.

2. Make it executable if it isn't so by doing chmod +x NVIDIA-Linux-x86-1.0-7664-pkg1.run

3. Edit /etc/inittab and set the default runlevel to 3, and restart your computer. This tells linux to start in textmode, since you're going to tinker with the graphicdrivers.

4. If you're lucky you can run it by doing ./NVIDIA-Linux-x86-1.0-7664-pkg1.run and it asks if you want to download a precompiled package from the net. This doesn't work for me (I'm using Slackware) so maybe you have to compile it on your own. If so, continue to 5. Otherwise you can skip five.

5. Make sure that the kernel headers are installed. You should have some package for this I guess. Tell the installer that you don't want to fetch something from the net, and let it compile it for you.

6. Edit the X file. Depending on what you have it's called xorg.conf or XF86Config and you should find it in /etc/X11/. Scroll down until you find the graphics section. You should see a section named Device which has an attribute called Driver. This is probably set to vesa or nv or something. Change this to nvidia, and then you're ready to go! Edit /etc/inittab again and change the runlevel to 4 and restart the computer. Though you might want to try startx first to make sure it works. Then you should have 3d-acceleration!

And now that I've written all this I notice there is a special readme for suse users here. But you've read them already, right?

Anyway, this got rather lengthy, but I hope it helps you. Ask if you get any trouble.

yeah that's the way I used to do it in the old days. Getting my hands dirty and actually manually editing my XF6Config file!
There really is no need now with the latest nvidia drivers unless something goes terribly wrong.
this is the way I've been doing it lately and it's been working for me on my suse box:
1) Kernel sources must be installed and configured. Usually this means
installing the 'kernel-source', 'make' and 'gcc' packages with YaST2.
Update it - if not already done - via YaST2 Online Update (YOU).

2) Use the nvidia installer for 1.0-7664.

modprobe agpgart
sh NVIDIA-Linux-x86-1.0-7664-pkg1.run -q

3) Configure XFree86 with

sax2 -m 0=nvidia (0 is a digit, not a letter!)

NOTE: There is no need to try to enable 3D support. It's already
enabled, when the nvidia driver is running.

The thing that might throw you off is that the gui might still say that there is no 3d acceleration even though there is. This bug has been around for a while now so to really make sure you got 3d accelration try running tux racer or some other 3d program and see how it runs.


Share this post


Link to post
Share on other sites
okay I found kernel-source but it won't let me install it in yast, I had to goto the SuSE Downlaod page to get it(same with FireFox =P). It's In Yast under Standard Kernel but won't let me check it off as something I want to install. I however did not find make or gcc. I'm still downloading it and I'll tell you what I get.

Share this post


Link to post
Share on other sites
okay now it says I have kernel but still no gcc or make. When i run the installer it says it needs those though. Do you think it is insatlled? I figured the 3D stuff didn't work becasue all 3D games are super chuggy, like 1fps.

Share this post


Link to post
Share on other sites
probably because it's from a CD that came with a book. I notice when I go to configure the graphics that GeForce FX 5500 isn't an otion. Does this mean SuSE doesn't support this card?

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!