Jump to content
  • Advertisement
Sign in to follow this  
cifs

OpenGL OpenGL - TexFont problem/question

This topic is 4930 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I am calling txfRenderString() and getting funny results... It is easier to see when I turn GL_BLEND off when drawn over a textured backgroup... The first character is displayed correctly, the second and subsequent characters seem to be displayed in their rectanges which are offest from their preceeding character by less then 100% of the preceeding characters rectangle. Actually this would produce correct spacing of the characters with one exception. The rectangle of the preceeding character totally overwrites the start of the current character. If I go into TexFont.c and modify the txfRenderString() routine to move 0.001 on the Z axis after each character it seems to work... but the result is not great for viewing. Is this a Driver problem or am I missing something in OpenGL?? Any Ideas? Thanks ? P.S: With GL_BLEND on, the backgroup appears in the overlapped section. Running OpenGL on Windows 2000 with GLUT 3.7

Share this post


Link to post
Share on other sites
Advertisement
Thats it!!!! Thanks ....

Maybe someone should put that in the documentation for TexFont.

Many Many, Thanks Again

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!