Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

PSioNiC

texture / color mixing

This topic is 6590 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

ok my problem is with texture mapping and glColor. when i try to texture map something if i dont specify a color with the texture, i will just get black. if i do specify a color, opengl will mix that color with my texture. is there something i enabled by accident? is their something i forgot to do?

Share this post


Link to post
Share on other sites
Advertisement
there''s no need to disable anything, just set the colour to all white and the texture will look normal

-mike

Share this post


Link to post
Share on other sites
Or you could add this line

glDisable(GL_COLOR_MATERIAL);

That should do it... If not, do what was first posted with the whole changing the colour to white... It''s that easy.

S.

Share this post


Link to post
Share on other sites
i down think so
i use GL_MODULATE GL_COLOR_MATERIAL and lighting
it works normal
but i remember time them polygon was black

you need to determine material propertys!

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!